Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 71
  1. #1
    canadianRxtX's Avatar
    Join Date
    Mar 2009
    Location
    Southern Ontario
    Posts
    364

    Exclamation 08 rxt-x 50hrs, noticing throttle lag occasionally?

    Hey guys not sure if any of you have experienced this- 08 with 50hours on it, bone stock. Before I put it away last winter it was getting some occasional throttle lags, i.e. If i punched it it would lag for a second or two before picking up the RPMS and taking off. It only happened maybe 5% of the time. Asked the dealer to check it when I was getting it winterized but i think he forgot/didnt know what to look for. Should I check throttle body/throttle cable/ SC hoses for splits? RPMs are normal its just has me a little worried reading the threads about X model washers blowing up. I do ride this thing very hard as it is rough rough water where I ride quite often not much can do about that


    also I would like to remove the exhaust baffle on it and install an intake grate, its still under a year of warranty so I want to keep it legit until after warranty is over any of you do these mods ONLY? notice better performance?


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    As far as the hesitation goes, I would get all the old gas out of the tank and put in some fresh high-octane gas as see if that helps. If it doesn't I would put some new plugs in.

    As far as mods, most (if not all) bolt on mods are not going to void your warranty. You will get 2-3 mph and better gas mileage by changing grates. A 4" air intake and impeller repitch will help too... Ron

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by canadianRxtX View Post
    I do ride this thing very hard as it is rough rough water where I ride quite often
    I would be willing to bet your supercharger clutch is slipping.

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by Green Hulk View Post
    I would be willing to bet your supercharger clutch is slipping.
    I agree. Also, the more you let it slip the more likely you are to have washer failure.

  5. #5
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by speedskixp View Post
    I agree. Also, the more you let it slip the more likely you are to have washer failure.
    +2

    My X ski was slipping pretty good at 40 hours.

  6. #6
    canadianRxtX's Avatar
    Join Date
    Mar 2009
    Location
    Southern Ontario
    Posts
    364
    Ok thanks fro the info guys. I will have him check the SC slip. I bet you are on the money with that. IT seems to dscribe the feeling i was getting when it lagged a bit, takign longer to spool up then it should. like i said tho only about 5-10% of the time i would punch it.
    I forgot to mention, i put brand new plugs in at about 45 hours when I started ntoicing this, didnt help whatsoever. And I always run 91 gas( the best u can get in Canada at 99% of gas stations) , and when it sits for more then a week or two i put stabil in it. It is used about 4 times a week in the summer so it never sits for very long.

    So the better grate will actually help the fuel mileage a bit? thats a cool bonus. I am leaning towards the RIVA from what i see on here with your testing. And the straight pipe only because I love the sounds of my X it rocks everything else out there stock, i cant wait to make it louder.

  7. #7
    meansvt00's Avatar
    Join Date
    Jul 2007
    Location
    New Jersey
    Posts
    237
    does anyone think it possible that the wear ring needs to be replaced
    i thought your supposed to change it at 50 hrs that would cause some cavitation. that can feel like a lag you explained

  8. #8
    canadianRxtX's Avatar
    Join Date
    Mar 2009
    Location
    Southern Ontario
    Posts
    364
    Svt I doubt it is the wear ring, I know they do wear out slowly but my machine has never touched sand or sucked any up. Also, if the wear ring was worn i think it would lag most, of not all of the time I punch it. But i will have the dealer check out the wear ring too, after all I want max speed out of this thing all the time.
    I called the dealer and hes going to check the SC slip for me in the next couple of weeks. Ill keep it posted on what the results are.

  9. #9
    canadianRxtX's Avatar
    Join Date
    Mar 2009
    Location
    Southern Ontario
    Posts
    364
    havent even looked at it yet... argh. and it looks like its going to be nice weather this weekend for the first ride of the year!!!

  10. #10
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Get the SCer checked out ASAP.

Page 1 of 8 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB wtb steering/ finger throttle set up 08 rxt 215
    By JohnnyG. in forum Sea Doo 4Tec Skis
    Replies: 2
    Last Post: 05-23-2013, 11:07 AM
  2. WTB - Parts finger throttle and r&d intake grate for 08 RXT
    By otoss in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 02-22-2012, 02:27 PM
  3. 07rxt vs 08 rxt-x
    By chokehold in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-25-2007, 01:43 PM
  4. 08 RXT 215 vs 08 GTX Limited
    By paca22 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-23-2007, 03:08 PM
  5. 07 Or 08 Rxt
    By tony4963 in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-31-2007, 10:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •