Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22

Thread: Rich A/F ?

  1. #1
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577

    Rich A/F ?

    Okay, I have been recording about 11.5 A/F even after calibrating the tar out of the sensor. I even got another sensor today to make sure it wasn't the sensor.

    Still reading 11.5. Frap! I can't see anything obvious, what could be causing this???? From the looks of it I may have been running rich for a while now.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Dave, i would hardly call 11.5 being too rich. Ideally you want to be at 11.7 - 11.9 at WOT so you aren't that far off.

  3. #3
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by Green Hulk View Post
    Dave, i would hardly call 11.5 being too rich. Ideally you want to be at 11.7 - 11.9 at WOT so you aren't that far off.
    Okay, maybe I have 14.7 drill into my head a bit too much. Getting the spackle out


    BTW, thanks for the tip on the sensor part number!

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Yep, your AFR is about where you want it on a forced induction motor.

  5. #5
    Quote Originally Posted by Green Hulk View Post
    Yep, your AFR is about where you want it on a forced induction motor.
    +1

  6. #6
    Lean ain't always mean, keep it safe.

  7. #7
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    This AFR was at IDLE

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Good AFR for idle..... Let us know where it's at when you make a WOT hit on it.

    BTW, during cruising speeds you will see readings in the high 13's maybe even low 14's. This is okay as the engine is not under load and this is the way the ECU is mapped. Running on the lean side at cruising speed/part throttle helps get those wonderful award winning low emissions and better fuel economy

  9. #9
    I was about to test this when my sc clutch went out....It was a sad day...I had everything ready...

  10. #10
    stangbang's Avatar
    Join Date
    Oct 2007
    Location
    West Palm Beach
    Posts
    844
    +1
    129
    Yes if your wot is at 11.5, then you are doing pretty good. I like to keep my boosted engines at 11.2 cause I like to play with timing. Plus you want it a little lower if you are going to be beating on it in the heat.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. looking a lil rich pics
    By Bone1050 in forum Polaris PWC Performance
    Replies: 26
    Last Post: 06-11-2007, 04:36 AM
  2. running rich?
    By shhr in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-02-2007, 10:20 PM
  3. Happy Bday Rich!!!!!
    By Duke in forum Yamaha Open Discussion
    Replies: 19
    Last Post: 03-11-2007, 09:20 PM
  4. HAPPY BIRTHDAY RICH!!!
    By RustySeaRustyDoo in forum Sea Doo Open Discussion
    Replies: 23
    Last Post: 01-06-2006, 10:54 PM
  5. Question for rich.
    By ccassone in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 12-03-2005, 09:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •