Results 1 to 5 of 5
  1. #1

    Locating Debris between oil pumps?

    I lost the gear, one washer and all needle bearings off the sc. Have found 98% of it. Hardly anything in the oil filter. My question is; how does the oil and debris get to the front pump, and can that area be flushed? Also, can the pto and oil separater housings be remachined to remove scarring?


  2. #2
    red flash11 dgconlee01's Avatar
    Join Date
    Jun 2008
    Location
    Randolph, Ms
    Posts
    32
    Ha i just had the same thing happen but my housein is fine.. i can't find the spacer that goes behind the nut...how does your front pump look?

  3. #3
    Both of my pumps are toast. Plus the housings they go into. So is the sc housing. Bearing failure either caused or resulted from the loss of gear,ect. So bearing bore is damaged.

  4. #4
    red flash11 dgconlee01's Avatar
    Join Date
    Jun 2008
    Location
    Randolph, Ms
    Posts
    32
    wow..not sure about resurfacing the housein but the pumps are inexpensive to replace..it must have run for a while after the nut came off...i poored oil and diesel through mine when i had my engine out to flush as much debris out as possible..i am having to take the bottom half off to find the spacer otherwise when my washers failed i did not remove i just flushed flushed and once i got it back in i changed the oil after running it about 30 minutes that wrked for me till l lost my nut ha

  5. #5
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,585
    +1
    4,795
    Quote Originally Posted by laker9142 View Post
    I lost the gear, one washer and all needle bearings off the sc. Have found 98% of it. Hardly anything in the oil filter. My question is; how does the oil and debris get to the front pump, and can that area be flushed?
    Not sure about the oil and debris,
    but I did find a Honda F-12X stuck inside mine one time...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mystery debris in NA 130 under primary oil pump screen
    By EXTremist in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-18-2014, 03:28 PM
  2. 1998 XL1200 Oil Pump return hose location
    By bigjjj in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 07-01-2009, 12:15 AM
  3. Oil Filter Cap? Good Oil Pump, Mine Sucks!
    By Haislip in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-27-2006, 01:19 PM
  4. Missing Oil Pump on 06 models
    By bic1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-05-2006, 03:15 PM
  5. will a generic marine oil pump suffice to change my RXP'oil?
    By theantiRXP in forum Sea Doo How To & FAQs
    Replies: 2
    Last Post: 06-25-2005, 12:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •