Results 1 to 9 of 9

Thread: TOPS valve?

  1. #1
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366

    TOPS valve?

    I need to replace the TOPS valve, Im getting a P-1502 err code.
    What part number is it and how much is the cost?
    any help is greatly appreciated


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Need to know what year your ski....

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by xBigDaddyx117 View Post
    I need to replace the TOPS valve, Im getting a P-1502 err code.
    What part number is it and how much is the cost?
    any help is greatly appreciated

    Here you go
    http://partsfinder.onlinemicrofiche....Seadoo_PWC.asp

    Select your year and model of ski. Find the tops valve in the microfiche and you will also see the price.

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    since he's saying tops valve... i'm guessing he has an original styled front separator cover with an electronic tops valve that works off a mercury switch...

    have you pin-pointed it to definitely being a faulty tops valve? is it sticking? making odd buzzing/humming noises even when the motor isn't running? does the ski run fine but ur just getting a code? or it runs like a bag of crap in limp mode or something? ... do u have a catch can and is it filling up it puking oil at all?

  5. #5
    Quote Originally Posted by Shibby1485 View Post
    since he's saying tops valve... i'm guessing he has an original styled front separator cover with an electronic tops valve that works off a mercury switch...

    have you pin-pointed it to definitely being a faulty tops valve? is it sticking? making odd buzzing/humming noises even when the motor isn't running? does the ski run fine but ur just getting a code? or it runs like a bag of crap in limp mode or something? ... do u have a catch can and is it filling up it puking oil at all?

    We have one doing the same thing going in limp mode.It is a 05 and I think it might be the TOPS.What do you thin Shibby?

  6. #6
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    "usually" the actual TOPS valve assembly on top of the front separator wont cause limp mode.... i've seen them fail, and the plunger inside stay closed rather than opening like it should when the key is placed on or when the motor is running... then the crankcase builds pressure and pushes the plunger and the quick escape of pressure pushes a little oil with it...

    have seen some of the mercury switches located on the MPEM brackets break loose and bang around or rotate sideways or upside down causing running problems.. or just simply go bad also

    unbolt the TOPS valve from the top of the separator cover and put the key on... see if it sucks up and open to vent... pull the key and there's a time delay with the electrical system and the plunger should snap back closed... can try diagnosing it that way.

    the 06+ models with that new switch housing that has the ball rolling around in it... have seen a good number of those go bad... but none of these have an electronically actuated breather or tops valve... just that mechanical vent on the side of the head and a switch that tells the ECU the degrees of rotation of the hull..

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    hey Mitch... i got one (unrelated to TOPS) i need to troubleshoot that i've never seen... sent you a PM if ya dont mind! see if your ideas are the same as mine or if u have other ideas

  8. #8
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    Hey guys, I have been down for a while now, I have no internet and my canal was dry. I had way to much stuff hitting me at once, car breaking down, loseing my job to layoffs, computer dieing, lost my house had to move back with my dad, and now I have to sell off all my stuff so he don't lose his. I havent been on this site since my last post and I really need to sell my seadoo, I know, After all that damn work and not even get to enjoy it once, and I still have to figure out the tops crap.

    If someone you know wants to buy this 02hull with 03 SC engine seadoo tell em to pm me please.

    I will see if that thing is sticking or not, but it will be a few days.

    Thanks everyone for all the help you given.

  9. #9
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Hey BigDaddy, sorry to hear about everything. Hope everything works out in the future... Ron

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. where is the tops valve/solenoid in 07 ski RXT/RXP??
    By Turbo Retro in forum 4-Tec Performance
    Replies: 1
    Last Post: 12-23-2009, 10:21 PM
  2. Tops Valve Question
    By JimC in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-05-2009, 10:54 PM
  3. TOPS Valve on 07 RXT
    By lafjax in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-10-2007, 09:09 PM
  4. need info on TOPS valve
    By Bamafanatic in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-26-2007, 09:21 AM
  5. need info on TOPS valve
    By Bamafanatic in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-26-2007, 09:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •