Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1
    fh23rxp-x's Avatar
    Join Date
    May 2008
    Location
    Miami
    Posts
    462

    i need some serious help ..

    i just installed a riva trhu hull and some other mods ( sponson , block offs ) over the winters the sounds is awsome but i am noticing that my ski is not pulling as hard on top end the acceleration is way harder than before .

    the ski has about 50 hours , and the does not turn over 7900 rpms .

    could it be, since i have a stock prop and now with the thru hull my acceleration is harder i am not noticing a such a strong pull on top end , the ski pulls hard of the hole but then top end is kind of weak ....

    do i have change my prop or repitch it , or could this be the wachers from the supercharger . i ve heard a few guys talking about this . i also order a worx grate and working on 4 in intake ... please guys help

    thanks


  2. #2

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    what were the rpms before?? if they were 8100 and now 7900 check for boost leakage

  3. #3
    fh23rxp-x's Avatar
    Join Date
    May 2008
    Location
    Miami
    Posts
    462
    Quote Originally Posted by busa504 View Post
    what were the rpms before?? if they were 8100 and now 7900 check for boost leakage

    i dont think my ski never pass 8000 rpms .

  4. #4
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    The SCer washers may not be the problem, but I would replace them now with RIVA washers. What was the ski pulling RPM wise before mods?

  5. #5
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    What are you running the trim at? That has a great effect on rpms. Get a GPS, find some smooth water and find your best trim setting for best speed. Note RPMs and speed.

  6. #6
    fh23rxp-x's Avatar
    Join Date
    May 2008
    Location
    Miami
    Posts
    462
    Quote Originally Posted by jp1300r View Post
    The SCer washers may not be the problem, but I would replace them now with RIVA washers. What was the ski pulling RPM wise before mods?
    yeah i am planning to change my washers soon .....

    the rpm before the mods were about the same thing about 7900 and maybe 8000 .

  7. #7
    FrankieV123's Avatar
    Join Date
    Aug 2008
    Location
    Florida -JERSEY
    Posts
    260
    +1
    1
    My RXP-Xs...both never topped 7800 rpm then i realized too much OIL..check your dipstick make sure between notches...now they run 7900 rpm...still cant get em to 8000 but i think my prop is a lil dinged soo im repacing it with a 15/22r in a month....air intake will also bring ur RPMS up 100-200 so u might wanna stay where you are if you dont want to mess with a prop...and top end will stay around 70ish with the stock grate...you will notice a difference with the worx

  8. #8
    fh23rxp-x's Avatar
    Join Date
    May 2008
    Location
    Miami
    Posts
    462
    Quote Originally Posted by jp1300r View Post
    What are you running the trim at? That has a great effect on rpms. Get a GPS, find some smooth water and find your best trim setting for best speed. Note RPMs and speed.

    yeah i gotta do that some time this week

    i need to figure out the probleam because this is killing

  9. #9
    fh23rxp-x's Avatar
    Join Date
    May 2008
    Location
    Miami
    Posts
    462
    Quote Originally Posted by FrankieV123 View Post
    My RXP-Xs...both never topped 7800 rpm then i realized too much OIL..check your dipstick make sure between notches...now they run 7900 rpm...still cant get em to 8000 but i think my prop is a lil dinged soo im repacing it with a 15/22r in a month....air intake will also bring ur RPMS up 100-200 so u might wanna stay where you are if you dont want to mess with a prop...and top end will stay around 70ish with the stock grate...you will notice a difference with the worx
    how is the worxs grate off the hole did you feel any cavitation . and how many mph did you gain

  10. #10
    It is the wear ring!! If your supercharger was bad the RPM drop would be much more!! or it could be a bad impeller!! it is not the SC!!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. All PET owners: Need some serious help
    By Racecar_Dave in forum Yamaha How To & FAQs
    Replies: 15
    Last Post: 11-15-2009, 07:44 PM
  2. plz check this post i need some serious help prop o ring problems
    By Gio GP1200R in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-19-2008, 01:37 PM
  3. Need some more help i think
    By big83bronco in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 06-19-2006, 09:56 PM
  4. First test with 2 Intercoolers Need Some Impeller Help!
    By somefun in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-14-2006, 07:08 PM
  5. Need some quick help
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-04-2006, 01:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •