Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    RXP-X supercharger washer failed

    Hi,
    Last weekend my RXP-X (37 Hours in it) started to experience some intermitent lost in speed expecially at WOT. Called the dealer, and just got the news that the clutch washer as failed!
    Prior to that I've been complaining about some vibration at mid to high speed, and I wonder if that could contribute or be related to the mentioned problem.
    As anyone sufered from this type of vibration, prior to the clutch failure?
    thanks in advance,
    Pedro


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Sounds fishy If your washers failed... you would not have had any WOT speed

  3. #3
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by pguerreiro View Post
    Hi,
    Last weekend my RXP-X (37 Hours in it) started to experience some intermitent lost in speed expecially at WOT. Called the dealer, and just got the news that the clutch washer as failed!
    Prior to that I've been complaining about some vibration at mid to high speed, and I wonder if that could contribute or be related to the mentioned problem.
    As anyone sufered from this type of vibration, prior to the clutch failure?
    thanks in advance,
    Pedro
    sorry to hear more bad news. The stock intake grate will make some vibration, not sure if your feeling that?

  4. #4
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,018
    +1
    304
    Clutch/washer failure sucks. Hate to hear that... good luck.

    On the other hand, can't loss of intermittent speed w/vibration be a result of trash on the impeller/grate or a gouge in the wear ring. I suffered this issue last summer from a bad gouge to the wear ring.

  5. #5
    Quote Originally Posted by 83Gator View Post
    Clutch/washer failure sucks. Hate to hear that... good luck.

    On the other hand, can't loss of intermittent speed w/vibration be a result of trash on the impeller/grate or a gouge in the wear ring. I suffered this issue last summer from a bad gouge to the wear ring.
    Fortunatly the ski is still on warranty, and the dealer will have to repair it at no cost for me... hopefully... Hope the washers haven't broken anything apart from it self..

    As for the vibration, I don't think that is it... I've been feeling it almost since day one I've ride the ski. It sounds like the driveshaft is torn or something, but I know that's impossible, with the increase driveshaft width on the new X model. Any way It's strange feeling. I wonder if anyone as felt that before.

    thanks
    Pedro

  6. #6
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Since your ski is at the dealer have them check the motor alignment. That can cause vibration.

  7. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by aha View Post
    Since your ski is at the dealer have them check the motor alignment. That can cause vibration.
    +1

  8. #8
    Quote Originally Posted by aha View Post
    Since your ski is at the dealer have them check the motor alignment. That can cause vibration.
    Good ideia, I will ask for that. Do you know similar cases? And... do you think that could contribute to the premature ware on the washers?

  9. #9
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,338
    +1
    121
    Any chance you ride your RXP-X like this?


  10. #10
    0607rxp's Avatar
    Join Date
    Jan 2009
    Location
    boca raton
    Posts
    35
    that suck good luck on getting it fix. i never had any vibration.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Supercharger Washers
    By Azzo in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-26-2009, 07:15 PM
  2. RXP-X Supercharger washers
    By pdxrealtor in forum 4-Tec Performance
    Replies: 20
    Last Post: 04-06-2009, 06:44 PM
  3. ARE 05 and 06 RXP metal supercharger washers the same???
    By awague2 in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-05-2008, 10:45 AM
  4. 2004 RXP ECU - Supercharger Washers?
    By Octaneauto in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-22-2007, 06:13 PM
  5. Replies: 6
    Last Post: 05-26-2007, 04:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •