Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    newbie question. spark on 2 0f 3 cylinders 1996 sl900

    Hey everyone. New to pwc's, and i just picked up a project 1996 sl900. ski run's but only on 2 of 3 cylinders. there is no spark on the forward most cylinder. Can someone please give me some tech support on what to check and how to check it please?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Welcome to the Hulk!

    Click here for the Polaris Service Manual, and other useful info.

    Look in the electrical section of the manual, and check the connections and ohm measurements of the ignition coils. Also check the stator Hall Effect sensor.

    There is an Ignition Update Kit available for your engine. If you do not yet have the update installed, then you may need it. Check the part number on the CDI module in the electrical box to see whether you have the original, or the updated version.

    Note that the diagnostics in the 1992-1998 manual are for the original parts. If you have the Update Kit installed, then the stator coil measurements are different.

  3. #3
    Thanks for the quick reply. Even if i check the part # on the cdi how do i know if it's the original or the updated version. If it is the original does polaris still offer this part of does someone offer it aftermarket.

  4. #4
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    Welcome to the Green Hulk sl900dave, You came to the right place. These guys will get you thru it!!!! Take your time and listen to what they tell you, plus they will help you find the parts you need!!!! Great forum they have helped me thru everything.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by sl900dave View Post
    ...if I check the part # on the CDI how do i know if it's the original or the updated version.

    If it is the original does Polaris still offer this part...
    Click here for a link to the Polaris Industries part number database. Use Advanced Search to check your part number.

    There are additional links there to threads discussing which CDI part numbers are old vs. new.

    The update kits are still available from any authorized Polaris OEM parts distributor or dealer.

  6. #6
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    If the CDI has a red plug on the bottom, it is the updated style. If it does not, it is old. I wouldn't even ride a 900/1050 that had the old ignition in it...it was junk and is just waiting to strand you.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by PolarisNut View Post
    If the CDI has a red plug on the bottom, it is the updated style. If it does not, it is old...
    Are you referring to the 9-pin serial computer port, or the red potting compound used to seal the CDI innards?

  8. #8
    i do have the factory service manual and will start checking this stuff tomorrow. i'll let you know as i'm sure i will need your help still. thanks again

  9. #9
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Quote Originally Posted by sl900dave View Post
    ski run's but only on 2 of 3 cylinders. there is no spark on the forward most cylinder. Can someone please give me some tech support on what to check and how to check it please?
    Take the boot off the MAG plug wire (forward most cylinder) and trim 1/8th to 3/16 of an inch off the end of the wire, put boot back on and test for spark.

  10. #10
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    Quote Originally Posted by K447 View Post
    Are you referring to the 9-pin serial computer port, or the red potting compound used to seal the CDI innards?
    Sorry...the 9-pin serial port cover...but now that I think about it, I have seen some with a black cover also, IIRC. Bottom line, if it has a 9-pin serial (RS232) port, it is the new style.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Polaris Genesis i - Spark on 1 of 3 cylinders
    By aussinole in forum Polaris PWC Performance
    Replies: 26
    Last Post: 10-15-2013, 04:59 PM
  2. newbie question, tabs on stck intk grate
    By outonalimb in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-15-2009, 03:49 PM
  3. Newbie Question about handlebars on a 1998 GP1200
    By CJean386 in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 06-01-2007, 12:18 PM
  4. Newbie needs advice on dead cylinder
    By blue00ws6 in forum Yamaha How To & FAQs
    Replies: 6
    Last Post: 05-29-2007, 07:31 PM
  5. newbie questions on trailer and ride plate
    By NJRXP in forum Sea Doo Open Discussion
    Replies: 27
    Last Post: 02-05-2007, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •