Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 50
  1. #1
    "Tearing it up on the water" seadoobutch787's Avatar
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    533

    96xp engine problem?

    I wrote a couple days ago that my 96xp that has 42 novi's and a spec 2 was running awesome. I just didn't see more than 6900rpms and it seemed like it was boucing off the rev limiter. I took the plugs out and looked that them last week and they were coco brown and a lil wet after doing a plug chop. I took the boat out today and there was less chop and the boat ran awesome in the beginning but it still didn't want to hit hi numbers on the tach. I took it over to a section on the lake where it was calm and did a full throttle plug chop, the boat cut off and i had to start it again, after that it started acting funny it was running good on low end and mid range but it seemed like it was bogging and the tach said 6700 and then another run 5700. The ski would fire right up in the water but it's performance is laking now. The plugs never got hot or the cylinders when i touched them. Well i got home and took out the mag plug and did a compression check it reads about 165, the rear i took out the plug and the insulator is gone and it looks like DETO, the compression is about 150. I run a high output mikuni fuel pump with a 60 mikuni jet in the return line, My squish is around .60 i thought that was plenty good for running a spec 2. The most i seen on a run today was 7000rpms. I also checked the rectifier and it read 12.75 at 5800 rpms so that should be good. Here is the pics of the motor.

    The more i look at the rear spark plug the more i think that the insulator broke off the stem and made it into my motor, if i look into the spark plug it looks like a clean break, like i said this motor ran awesome the last weekend i rode it, the same water temp and air temp and the same plug chop i did on a wot run. The cylinder wall in the rear has NO scoring.

    I use a siphon feed sand blaster to clean up fouled or dirty spark plugs and i usually run it at 100 psi so that might have fractured the insulator and it just took some running of the engine to break her loose, im hoping LOL


  2. #2
    "Tearing it up on the water" seadoobutch787's Avatar
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    533
    Here are the pics
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	picresized_th_1239273961_Picture 001.jpg 
Views:	83 
Size:	119.6 KB 
ID:	125283   Click image for larger version. 

Name:	picresized_th_1239274006_Picture 002.jpg 
Views:	73 
Size:	120.2 KB 
ID:	125284   Click image for larger version. 

Name:	picresized_th_1239274061_Picture 003.jpg 
Views:	77 
Size:	116.3 KB 
ID:	125285   Click image for larger version. 

Name:	picresized_th_1239274096_Picture 004.jpg 
Views:	83 
Size:	118.8 KB 
ID:	125286   Click image for larger version. 

Name:	picresized_th_1239274137_Picture 005.jpg 
Views:	78 
Size:	125.9 KB 
ID:	125287   Click image for larger version. 

Name:	picresized_th_1239274428_Picture 006.jpg 
Views:	85 
Size:	87.9 KB 
ID:	125288  


  3. #3
    Rampage's Avatar
    Join Date
    Sep 2007
    Location
    Holland, Michigan, United States
    Posts
    2,932
    Uh oh... Guess this means our chances of riding this weekend just got lower?

  4. #4
    "Tearing it up on the water" seadoobutch787's Avatar
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    533
    I have 3 ski's Phil, 750ss and a 550 stand up. I will be running again with the seadoo in about 2 weeks.

  5. #5
    Trust me as I am no pro but to me you seem to have it right about detonation. I can always be wrong but If I remember correctly the good thing about detonation is there are a few things that you can do to help prevent it. Such as higher octaine fuel, adjust the carb to run richer and many more. Group k has a good wright up on this mater if you search for it. There can be alot more to your problem than what I am thinking so do your home work. I do believe that you may be able to come up with a answer to your problem. If it were me I would not rebuild top end untill you find what works good as a fix. I believe that it will still run strong with your compression readings and when you know you have the problem fixed then rebuild top end if you like. Keep in mind that I am no pro so do your home work and get it right. Ps even some of those who think they are pros get it wrong some times so get a few opinions. There are many pros on the enternet. Looks like a fuel related problem to me [NOT ENOUGH FUEL TO THAT CYLINDER]

  6. #6
    "Tearing it up on the water" seadoobutch787's Avatar
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    533
    I should have known the spec 2 is very touchy!!!

    looks like 110 from now on LOL

    At what rpms does deto occur, like i said i was never over 7000 rpms, im wondering on the 42's do i need to run a bigger size in the pto carb, right now im at 162.5 on the mains, But what kills me is last weekend i had no problems and the boat ran great but never really hit over 6900, the plugs were both coco brown and the cylinders and the plugs were never to hot to handle.

  7. #7
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    It was deto. Aren't you running 83/85 nozzles? Any trim tabs? Sorry I can't remember your whole setup Mike. What timing curve are you running? And what revlimiter?

    Look at your detoed piston. The piston was eroding around the top ring gap. When it shut off running wot, you stuck it.

  8. #8
    "Tearing it up on the water" seadoobutch787's Avatar
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    533
    Do you think i should bore the 83/85 to 85/88 to be safe??

  9. #9
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by seadoobutch787 View Post
    Do you think i should bore the 83/85 to 85/88 to be safe??
    Most definitely. What about the trim tabs?

  10. #10
    "Tearing it up on the water" seadoobutch787's Avatar
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    533
    I have a MT rev limiter and it's set to 7500-7700rpms, i have a stock intake grate and a solas XO, my timing is set at -1 degree per the MT instructions.



    I have a set of R&D trim tabs on the back but not the pump extention is that a factor also?? I will bore out the cylinder and put a new pro x piston in. Im going to run half or full 110 octane just to be safe after this. I know that when the boat is dialed in at 7300-7400 rpms that's not pump gas safe. Im also boring the nozzles. This is my first deto lol i have run lean and scored pistons, i will have to put this piston on my shelf just to remind me.


    Is the motor being loaded down too much with the 83/85? I just know what a pain it is to have to pull the motor especially with a spec 2 hooked up, oh well it's still early in the season it's not like it's the 4th of July and i really need my boat out.

    Where is the best place to buy pro-x pistons?

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 gtx 4tec Check Engine problem.
    By kabab in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-28-2009, 03:30 AM
  2. RXP oil pump and engine problem?
    By pet in forum 4-Tec Performance
    Replies: 54
    Last Post: 07-27-2007, 08:12 AM
  3. '98 speedster 16' engine problem
    By trishark in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 07-09-2007, 12:35 PM
  4. Engine Problem, top speed RPM lost
    By BlackHawk in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-30-2006, 01:34 PM
  5. 02 GP 1200 engine problems
    By ADAMBOMB in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-23-2006, 12:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •