Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,975
    +1
    34

    Good progress today...

    Well this was a very productive weekend getting things done and fixing a few small things.

    First, my SL780 has not been started in about 2 years. If you look at this thread, I had a huge issue with too much fuel. Turns out the carbs were just sooo gunked up the fuel return orifice was clogged so all the fuel was going to the cylinders. I took apart completely and cleaned all the carbs, emptied the crank case of all the fuel (about 1.5 pints worth), hooked everything back up and she fired on the 2nd crank

    I also got the Pro fixed up. Thanks to 785 Lugs, a very nice Skat Trak 6 vane stainless steel stator and brand new Skat Trak 12/17 prop went in. Looking at the pictures, you think my chewed up prop and cavitated stator was the problem to my sluggish top end? I was only getting 60.0 MPH on the GPS and I sure hope this is going to make a difference. I also put in a Hotseat 6 degree wedge also care of 785 Lugs. A BIG thank you goes to Bob. I sincerely appreciate your help! Now I'm off to the lake tomorrow if I can figure out this MFD problem I'm having!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCN3287.JPG 
Views:	125 
Size:	1.03 MB 
ID:	125590   Click image for larger version. 

Name:	DSCN3288.JPG 
Views:	110 
Size:	1,014.9 KB 
ID:	125591   Click image for larger version. 

Name:	DSCN3289.JPG 
Views:	115 
Size:	985.2 KB 
ID:	125592   Click image for larger version. 

Name:	DSCN3290.JPG 
Views:	118 
Size:	1.04 MB 
ID:	125593   Click image for larger version. 

Name:	DSCN3293.JPG 
Views:	113 
Size:	1,018.6 KB 
ID:	125594  


  2. #2
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    Quote Originally Posted by hyoctane23 View Post
    Well this was a very productive weekend getting things done and fixing a few small things.

    First, my SL780 has not been started in about 2 years. If you look at this thread, I had a huge issue with too much fuel. Turns out the carbs were just sooo gunked up the fuel return orifice was clogged so all the fuel was going to the cylinders. I took apart completely and cleaned all the carbs, emptied the crank case of all the fuel (about 1.5 pints worth), hooked everything back up and she fired on the 2nd crank

    I also got the Pro fixed up. Thanks to 785 Lugs, a very nice Skat Trak 6 vane stainless steel stator and brand new Skat Trak 12/17 prop went in. Looking at the pictures, you think my chewed up prop and cavitated stator was the problem to my sluggish top end? I was only getting 60.0 MPH on the GPS and I sure hope this is going to make a difference. I also put in a Hotseat 6 degree wedge also care of 785 Lugs. A BIG thank you goes to Bob. I sincerely appreciate your help! Now I'm off to the lake tomorrow if I can figure out this MFD problem I'm having!
    Yes BOB is the man!!!

  3. #3
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by OLDJETSKIMAN View Post
    Yes BOB is the man!!!
    or is he a very sick and tristed girlJ/K i started early tonight
    mattman

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by hyoctane23 View Post
    ...SL780...my chewed up prop and cavitated stator was the problem to my sluggish top end? I was only getting 60.0 MPH on the GPS...
    You were able to get 60mph on GPS with that damaged impeller and stator, AND gummed up carbs?

  5. #5
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,975
    +1
    34
    Quote Originally Posted by K447 View Post
    You were able to get 60mph on GPS with that damaged impeller and stator, AND gummed up carbs?
    Well, almost. The gummed up carbs were in the SL780. The damaged impeller and stator were in the Pro.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Hmm, cleaned the 780 carbs and now she runs, imagine that???

    Seems to be the biggest issue on these aging Fuji engines. Easily fixable though.

    Good job.


    The impeller and stator would have affected the speed some I'm sure.

    You can send that damged impeller back to Skat for a rebuild. Runs between $80-100 depending if they need to add material to the blades. It'll be like new when they're done.

    Just in case you want a back up.

  7. #7
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,975
    +1
    34
    Man, the Pro pulls soo much harder on the top end with the new impeller and stator. The 780 is still having issues but I think I know what is the matter...

  8. #8
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,975
    +1
    34
    Here is a couple more pictures of the old parts from the Pro. Every vane on the stator has bad cavitation burns...probably from the dinged up impeller!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCN3339.JPG 
Views:	856 
Size:	1.02 MB 
ID:	126042   Click image for larger version. 

Name:	DSCN3340.JPG 
Views:	233 
Size:	953.0 KB 
ID:	126043  

  9. #9

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,703
    +1
    109
    Glad it helped you out

  10. #10
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    Quote Originally Posted by hyoctane23 View Post
    Here is a couple more pictures of the old parts from the Pro. Every vane on the stator has bad cavitation burns...probably from the dinged up impeller!
    WOW, I am feeling whole lot better on how mine looks now

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. If all days could be as good as today!
    By sHALlow in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-31-2010, 09:33 PM
  2. real good riding today
    By JIM'S PERFORMANCE in forum Southeast
    Replies: 29
    Last Post: 09-28-2008, 06:29 AM
  3. I heard a good one today
    By Fateracing in forum 4-Tec Performance
    Replies: 15
    Last Post: 09-03-2007, 10:10 AM
  4. Good results and riding today.
    By Sundance in forum 4-Tec Performance
    Replies: 12
    Last Post: 03-07-2006, 09:45 AM
  5. Got some good numbers today.
    By Alex_GPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 02-20-2006, 10:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •