Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Jun 2008
    Location
    florida
    Posts
    168

    96 xp wont go anywhere in the water

    My friend has a 96 xp it runs and sounds great out of the water when we put it in the water it is hard to start we have to get the pump out of the water to get it to start then when it starts its like its running very rich and when we try to ride it. it will not barly go above idle and will only run when you hold it full throttle but will still only barly idle the compression is 150 psi and the carb jetts are 142 highs and 70 lows and the needle and seat is 1.5 the carb settings are at 1 1/2 for the lows and the front carb high speed screw is at 1/4 out and the rear is at a 1/2 because im running air filters is there anything I can check to fix this problem
    thanks guys


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    If it's flooding he has a needle and seat sticking open. I'd replace the needle and seats and make sure the filter screens are clean. Are his fuel lines replaced? Did he remove the selector switch and clean the inside of that too?

  3. #3

    Join Date
    Jun 2008
    Location
    florida
    Posts
    168
    Yes the carbs are clean it has all new fuel lines and a brand new fuel selector so maybe its the needle and seat ?

  4. #4
    johnboygtv's Avatar
    Join Date
    Jul 2008
    Location
    England
    Posts
    44
    Quote Originally Posted by XP537 View Post
    Yes the carbs are clean it has all new fuel lines and a brand new fuel selector so maybe its the needle and seat ?

    Hi
    how old is the battery,as its easier to start out of the water than in it

  5. #5

    Join Date
    Jun 2008
    Location
    florida
    Posts
    168
    Its a new battery

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by XP537 View Post
    Yes the carbs are clean it has all new fuel lines and a brand new fuel selector so maybe its the needle and seat ?
    Yes, excessive fuel is a leaking needle and seat.

  7. #7
    Good info, I have a fried with an HX having the exact same trouble. I will help him re-build the carbs properly. I think his "mechanic" sucks, put in a new motor and nothing but trouble since.

  8. #8

    Join Date
    Jun 2008
    Location
    florida
    Posts
    168
    we rode the ski today it runs great but when we shut it off and it sits for a few mintues it will start but I had to hold the throttle wide open and it was just idleing again like it was loaded up on fuel so I shut the fuel off and as it burned most of the fuel it ran good the we turned the fuel back on and and it runs great again so now what does it sound like the problem is ? we switched the needle and seats out to 2.0 since we put filters on the carbs
    thanks again

  9. #9
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by XP537 View Post
    we rode the ski today it runs great but when we shut it off and it sits for a few mintues it will start but I had to hold the throttle wide open and it was just idleing again like it was loaded up on fuel so I shut the fuel off and as it burned most of the fuel it ran good the we turned the fuel back on and and it runs great again so now what does it sound like the problem is ? we switched the needle and seats out to 2.0 since we put filters on the carbs
    thanks again
    Dude...read your post. What are you saying? You rode it wthout changing the needle and seats? Or you changed them to the 2.0's prior to today's ride? I can't make heads or tails of it.

  10. #10

    Join Date
    Jun 2008
    Location
    florida
    Posts
    168
    we changed the needles an seats prior to today but they we from another set of carbs they were not new

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 xp wont run in water
    By 2 96xp in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-30-2015, 05:06 AM
  2. absolutely, positively, will not go WOT in the water!
    By Octoarms in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-04-2015, 04:04 PM
  3. Seadoo GSX Rfi 98', Wont take rpm. MAX 2400 in the water?
    By nicolajjetrider in forum 2-Stroke Performance
    Replies: 8
    Last Post: 07-25-2012, 03:45 AM
  4. !996 polaris slx will not go full throtle in the water
    By clint rogers in forum Polaris How To & FAQs
    Replies: 19
    Last Post: 07-30-2010, 05:06 PM
  5. Why slow go in the water?
    By DKFox in forum 2-Stroke Performance
    Replies: 3
    Last Post: 05-26-2009, 01:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •