Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1


  2. #2
    Zeke says hi! BLK MAJK's Avatar
    Join Date
    Mar 2009
    Location
    Haskins, OH
    Posts
    112


    ummmm.....wow.....I just don't have any other words

  3. #3
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    I do - What a "mucking foron!"

  4. #4
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    wow.

  5. #5
    Neighborhood Superman SlowStang305's Avatar
    Join Date
    Jun 2008
    Location
    FL
    Posts
    1,324
    +1
    7
    wow are you serious

  6. #6
    freakboy35's Avatar
    Join Date
    May 2008
    Location
    (ft lauderdale)
    Posts
    1,526
    +1
    8
    I'm sending those picture to by boat mechanic as if it was my boat. He should be calling me soon, hahahaha

  7. #7
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    OMG too funny. Glad it wasn't me! ...'JBWeld' Hahaha...

  8. #8
    FIRED!!! JP's Avatar
    Join Date
    Dec 2006
    Location
    Fort Lauderdale, FLORIDA baby...
    Posts
    3,505
    Post 15 is THE BEST...

    JP

  9. #9
    pwcbabe's Avatar
    Join Date
    Feb 2008
    Location
    so cal
    Posts
    327
    +1
    3
    oh, shit.

  10. #10
    Mike xsockguyx's Avatar
    Join Date
    Sep 2007
    Location
    NJ
    Posts
    1,744
    +1
    2
    lol.....................and the darwin awards goes too

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ride plate inserts gone bad
    By Hydrotherapy in forum Yamaha PWC Performance (2-stroke)
    Replies: 20
    Last Post: 08-09-2007, 12:07 AM
  2. maybe a sending unit gone bad??
    By mudd in forum Polaris Open Discussion
    Replies: 9
    Last Post: 08-08-2007, 10:12 PM
  3. EFI controler gone BAD??
    By flyboy in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-13-2006, 01:46 AM
  4. statue of liberty trip gone bad!!!
    By mxl16 in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 11-05-2005, 12:26 AM
  5. oil change gone bad
    By PAINKILLER in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-31-2005, 07:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •