Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1
    Legend in my own mind Sirhc7897's Avatar
    Join Date
    Aug 2005
    Location
    Lake Butler, FL.
    Posts
    1,140

    1200 Polaris (2000 SLX) sluggish turn over?

    My 1200 Polaris motor isn't wanting to turn over......

    It turns over easy by hand with the plugs out....

    Battery is fine

    When you try to fire it though it sounds likes it's struggling mightily and barely rolls over once every few seconds.....

    Starter gone bad? Maybe something else

    Thanks,
    Chris


  2. #2
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    Chris you should be able to track this down!...you know these things inside and out...or has working on Seadoos made you forget? Yeah it could be a bad solenoid/starter/bendix or with the Florida air, you might need to clean the electical connections for good contact...metal at connections maybe going soft?

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,598
    +1
    1,276
    As long as you are sure the battery is delivering more than 10.5 volts (measured at the battery posts with a multi-meter) while you are trying to crank the engine....

    Clean and check all the heavy battery and starter cable ends, including the engine ground end, and the end on the starter.

    Bypass the starter solenoid inside the electrical box by shorting the two heavy posts together. Do so using heavy pliers, and with a firm hand to minimize sparking. If the engine cranks smartly, the solenoid is bad.

    If still not good, then the starter is probably bad, or the starter ground has become corroded.

  4. #4
    Legend in my own mind Sirhc7897's Avatar
    Join Date
    Aug 2005
    Location
    Lake Butler, FL.
    Posts
    1,140
    Definately been a while since I had to troubleshoot one of these things......

    I'll start at the connections first and then work my way up from there.......

    I would say everything is corrosion free (based on the very minimal exposure to water and run time this thing has had since I put it together but I did notice today when I swapped the stock domes for 150psi domes that there was a bit of corrosion in the water chambers (almst looked like dried salt but this ski has not seen saltwater...)

    Guess this is what I get for tinkering with these things and then leaving them sit for almost a year......

  5. #5
    rlharrison60's Avatar
    Join Date
    Aug 2007
    Location
    Orange, Texas
    Posts
    1,091
    +1
    1
    I have a starter, if you need one.

  6. #6
    Legend in my own mind Sirhc7897's Avatar
    Join Date
    Aug 2005
    Location
    Lake Butler, FL.
    Posts
    1,140
    Quote Originally Posted by rlharrison60 View Post
    I have a starter, if you need one.
    is the starter on the MSX140 interchangeable with a older 1200 starter?

    After I check connections (which I'm 90% are going to be good as this thing was just fine when it went into mothballs) I was planning on swapping the starter off my MSX to see if that's it....

  7. #7
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    Quote Originally Posted by Sirhc7897 View Post
    is the starter on the MSX140 interchangeable with a older 1200 starter?

    After I check connections (which I'm 90% are going to be good as this thing was just fine when it went into mothballs) I was planning on swapping the starter off my MSX to see if that's it....
    I've seen the starter solenoids go bad, and not deliver the proper current to the starter motor...I'd use a jumper cable straight from the positive terminal on the battery to the positive starter post.

    All Polaris's 2 stroke starters are the same

  8. #8

    Smile

    starter brushes or brass brush holder/current carrier is broken,causing a very little of the starting voltage /amps going to brushes,its a normal occurrence on mitsu starters.most people never go that far just junk the starter,you can throw a rebuild kit in a mitsui starter for 27.00 and have a much better starter than buying a new after market for 150-200jmho>Marvin

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,598
    +1
    1,276
    Quote Originally Posted by mrjetskey View Post
    starter brushes or brass brush holder/current carrier is broken, causing a very little of the starting voltage /amps going to brushes, its a normal occurrence on mitsu starters.

    most people never go that far just junk the starter,

    you can throw a rebuild kit in a mitsui starter for 27.00 and have a much better starter than buying a new after market for 150-200...
    The Service Manuals actually go into some detail regarding starter motor repair.

    Where does one purchase the Mitsubishi starter motor rebuild kits?
    Is there a kit or part number for the rebuild kit?

  10. #10
    Legend in my own mind Sirhc7897's Avatar
    Join Date
    Aug 2005
    Location
    Lake Butler, FL.
    Posts
    1,140
    Quote Originally Posted by mrjetskey View Post
    starter brushes or brass brush holder/current carrier is broken,causing a very little of the starting voltage /amps going to brushes,its a normal occurrence on mitsu starters.most people never go that far just junk the starter,you can throw a rebuild kit in a mitsui starter for 27.00 and have a much better starter than buying a new after market for 150-200jmho>Marvin
    Certainly sounds good to me. I've never met a rebuild I was afraid of.....

    Now the trick will be to see if I can magically pull the starter without pulling the triples..... There is a suprising amount of room in the GSX so we'll see....

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris 1050 SLTX wont turn over
    By imdamnedifido in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 02-23-2016, 09:28 PM
  2. 2000 Polaris genesis 1200 PWC won't turn over, just a single click.
    By Masterdeminico in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-23-2015, 04:29 PM
  3. 1997 Polaris Sltx won't turn over....
    By taco157 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-29-2012, 11:36 PM
  4. FS: Polaris 2000 SLX
    By 32DegH2O in forum Polaris Classifieds
    Replies: 7
    Last Post: 08-17-2008, 10:20 AM
  5. 2000 Polaris Genesis FFI will not turn over
    By maui in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 04-10-2008, 08:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •