Results 1 to 8 of 8
  1. #1

    engine bogged and die now engine makes noise and wont stay running

    please help had one bar of fuel then engine bogged down then died .I can restart motor but awful sound plus dies as if bound up or fuel ....???? where do i start to pin point problem to engine goin south are a sensor etc. im lost please help


  2. #2
    redemn93's Avatar
    Join Date
    Aug 2006
    Location
    Jupiter Fl
    Posts
    272
    what kind of ski, etc?

    check your compression and let us know.

  3. #3

    copy will do

    Quote Originally Posted by redemn93 View Post
    what kind of ski, etc?

    check your compression and let us know.
    copy will do

  4. #4

    compresion check

    Quote Originally Posted by djlay57 View Post
    copy will do
    checked both pistons the one near the front has 145 psi and back has 70 psi and makes alot of noise ..like somethingis not good ???? some say since fuel was low it went to limp mode but not the noise ?

  5. #5
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8
    Well of the little i know, thats not good. Stock compression is 155 so the 145 isn't bad at all but the fact that the second piston is at such a lower compression is alarming!

  6. #6
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    pull the head and have a look. If you have compression like that the rear cylinder is toast. Time for a bore and new cylinders and maybe a crank. once you pull the head and it looks bad pull the jugs and see what you got. if its still bad...keep going. post some pics when you do...its easier to help when we can look at something.

    What kind of ski is this?

  7. #7
    redemn93's Avatar
    Join Date
    Aug 2006
    Location
    Jupiter Fl
    Posts
    272
    ya that rear cylinder is kaput. what year/model is the ski?

  8. #8
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    DO NOT RUN IT ANY MORE. Noise+low comp=dead cylinder. Either a bearing or the piston has failed (there are a number of scenarios, suffice it to say that it has croaked),

    You risk busting a case if you start it up and SD cases are not cheap (and if it is a 951 you will really be sorry).

    As Airborne said, it is dead. Pull it, break it down, and maybe kick some pics so we can tell you where you stand.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. problem with mys seadoo RXP-X 2008 ,starts and stalls.Wont stay running.
    By Bastiaan maarten Bok in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-01-2016, 10:53 PM
  2. Replies: 1
    Last Post: 08-26-2013, 08:07 PM
  3. Having running issues with Yamaha 1100 waverunner...wont stay running and backfires..
    By dontknowcrap in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 09-01-2012, 07:32 AM
  4. 1996 SL780 Got wet- now Bogs and Dies at WOT
    By cdiddy in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-26-2009, 10:16 AM
  5. 900zxi bogs and wont go over 40 mph
    By philsmtech in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 06-30-2008, 01:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •