Results 1 to 9 of 9
  1. #1

    Loud knocking from engine

    2004 Sportster, was running full speed / normal performance, boat started pulling to the right, then lost all thrust. Engine starts right up, but there is a very loud knocking / ratcheting sound while it is running. Mounts seem to be tight, no visible damage to the shaft. Knocking seems to be coming form the motor. Anyone had the pleasure of experiencing these symptoms?


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    welcome to GH!

    I dont know much about 4 strokes but for starters you accidentally posted in the 2 stroke section. You may want to have a Moderator move it to the 4-tec section

  3. #3
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    It could be a DI.

    Either way, sounds like a crank bearing.

    It would not be a good idea to run further without verification of the problem. You can damage the block/cases (and DI cases are, well, expensive, and I doubt a 4tec is much cheaper).

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    forgot that they put a DI in the 04's

  5. #5
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    No sweat. I had to look it up .

  6. #6

    LE DI

    It is an LE DI 130 HP 2 cylinder 2 stroke. Probably should have included that info. Thanks for the feedback.

  7. #7
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    First, pull the plugs and see if they look normal (if one has the electrode pushed closed or is covere in gray "stuff" then that is the cylinder).

    Pull the RAVEs and look into the cylinder while you rotate it by hand. Watch for the pistons to move smoothly. Rock the crank back and forth, look for delays in reaction, listen for unusual noise (they will make a little noise when rotated and a little more when rocked back and forth, but not a lot and no rattle/klunk stuff).

    Also take a close look at the pistons. Normaly a piston issue occurs on the exhaust port side (the hottest part) and will show up through the RAVE slot.

  8. #8

    Join Date
    Jul 2005
    Location
    Ohio
    Posts
    441
    +1
    1
    broken driveshaft, broken pump shaft, pull the pump anyway

    TLR

  9. #9
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by TLR View Post
    broken driveshaft, broken pump shaft, pull the pump anyway

    TLR
    +1

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1100 wave raider ticking noise from engine!!!Help
    By craneman in forum Yamaha Old School Skis
    Replies: 10
    Last Post: 09-19-2010, 12:36 AM
  2. Replies: 5
    Last Post: 07-27-2010, 06:25 PM
  3. White wire from engine
    By sl750-93 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-19-2009, 01:30 PM
  4. Strange knock from motor
    By banshee350racer in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 03-12-2009, 09:06 PM
  5. opinions wanted from engine builders
    By Jump On It in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 02-11-2008, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •