Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    Yet another EFI question...

    I have a factory 04 GPR except for the PVC version of the Free Flow Exhaust and I just installed the Riva's D-Plate and EFI Controller.

    I have searched the forums and tried many different settings on my EFI controller and I just wanted some opinions. Riva says for stage 1 to use 6919, which was obviously wrong for mine as it would never get above 25mph and just stumbled real bad.

    I then just went by the R&D directions, which is hard to do when the water is rough. I ended up with 3416. It seems to run fine but it doesn't seem to be much different then stock.

    Is there anything else I can do? I plan on adding a few more mods, once certain companies get things in stock. "cough cough R&D"


  2. #2
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    Try the stock settings you dont need any extra fuel with those mods.

    Also you may have fouled your plugs.

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    ttt

    yes, I agree, check those plugs like r33 said.....



    WFO, Abbott where ya'll at need some EFI troubleshooters here.....

    hang on super, they should be here shortly

  4. #4
    Quote Originally Posted by r33pwrd
    Try the stock settings you dont need any extra fuel with those mods.
    I thought I needed a little something because of the d-plate???

    Quote Originally Posted by r33pwrd
    Also you may have fouled your plugs.
    Not that it means much... but I did look at the plugs afterwars and they didn't look much different then normal.

  5. #5

    Join Date
    Apr 2006
    Location
    South MS
    Posts
    1,095
    Put an r&d race flame arrestor it will probably come alive. Then you will need a little extra fuel. With a filter, and d-plate I ran 4,4,1,7

    For now just turn yours down so more- try 2,2,1, 7 You might even can go leaner.

  6. #6
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    I am with Ron. You need more air in there or you will not see much in gains.

    I was going to say go with 5-5-1-7 or 4-4-1-7. If it surges in the midrange, open #4 to 8.

  7. #7
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,736
    +1
    96
    Quote Originally Posted by Ronn25
    Put an r&d race flame arrestor it will probably come alive. Then you will need a little extra fuel. With a filter, and d-plate I ran 4,4,1,7

    For now just turn yours down so more- try 2,2,1, 7 You might even can go leaner.

    Thats what i would have said in a nutshell. You need to get a tach first - because your boat will tell you more about whats going on by showing you it's rpms - the speed will take care of itself.

    Since you have a D-Plate / Controller / If you don't have a free-flow, then dont waste your time. Be sure that your holding the controller up in the right direction when deciding the "o'clock turns" ---put the green light on top (yellow below, then red, then no light).

    Check the plugs: Then try the 2-2-1-7 as stated above. Then try 3-3-1-7 and so on. There may be something else going on with your ski as well, that we are not aware of too, so i hope that you can find this.

    If all else fails, unplug the controller and put the cat con back in and see if it runs any better. You can also add a ride plate (aftermarket) which is worth 3 times the speed gains that you would have seen from the FC/D-plate. The ride plate is the single biggest "speed gain" you can bolt on to a GPR it can be worth 4ph in some cases.


    Let us know what happens - and get a tach (if you dont already have one).
    the best one out there is a PET2100DX (R&D sells them).

  8. #8
    Quote Originally Posted by ABBOTT
    Quote Originally Posted by Ronn25
    Put an r&d race flame arrestor it will probably come alive. Then you will need a little extra fuel. With a filter, and d-plate I ran 4,4,1,7

    For now just turn yours down so more- try 2,2,1, 7 You might even can go leaner.

    Thats what i would have said in a nutshell. You need to get a tach first - because your boat will tell you more about whats going on by showing you it's rpms - the speed will take care of itself.

    Since you have a D-Plate / Controller / If you don't have a free-flow, then dont waste your time. Be sure that your holding the controller up in the right direction when deciding the "o'clock turns" ---put the green light on top (yellow below, then red, then no light).

    Check the plugs: Then try the 2-2-1-7 as stated above. Then try 3-3-1-7 and so on. There may be something else going on with your ski as well, that we are not aware of too, so i hope that you can find this.

    If all else fails, unplug the controller and put the cat con back in and see if it runs any better. You can also add a ride plate (aftermarket) which is worth 3 times the speed gains that you would have seen from the FC/D-plate. The ride plate is the single biggest "speed gain" you can bolt on to a GPR it can be worth 4ph in some cases.


    Let us know what happens - and get a tach (if you dont already have one).
    the best one out there is a PET2100DX (R&D sells them).

    I do in fact have a tach already... removing the cat gave me 152 more rpms. It peaked at 7361 with no real speed increse. I am assuming this just means its time for another prop? I'm planning on the 05 conversion in the near future, so that should fix that.

    I would gladly get a rideplate if R&D would hurry up and make them! I've been in contact with Jim enough that I'm sure I am driving him nuts

    I hadn't really thought about a new air intake but maybe I should...

  9. #9

    Join Date
    Nov 2005
    Location
    Lafayette, La.
    Posts
    637
    Where are you guys buying are those high rpms at? I am having trouble getting rpms out of mine big time. If I get them higher then I lose mphs. It is getting to the point where it is not even fun riding anymore knowing that I have everything except porting and the rpms are not there. Tried different prop rpms went up a lil but mph came down alot.

  10. #10
    Quote Originally Posted by elebouef
    Where are you guys buying are those high rpms at?
    I have matched tires on mine

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yet another supercharger question!
    By SeadooTed in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 06-26-2011, 09:29 AM
  2. Yet another GPS mount question
    By lordblack in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 11-29-2007, 04:23 AM
  3. Yet another problem!!!! pump removal from hull question
    By spyder3000gtvr4 in forum Yamaha Open Discussion
    Replies: 14
    Last Post: 09-20-2007, 03:07 PM
  4. Another EFI question, arrgggghhh
    By shooter98xpl in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-01-2006, 10:13 PM
  5. YET another question
    By shooter98xpl in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 12-19-2005, 07:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •