Results 1 to 4 of 4
  1. #1
    2x 2004 Seadoo RXP. Milwaukee, Wisconsin. wisconsin_quat's Avatar
    Join Date
    Mar 2009
    Posts
    144

    So i pulled both of my wear rings out last night and looked at both impellers...

    1st machine -

    The wear ring looked fine... actually came out by hand without having to take off the impeller. Granted it was 45* in the garage so i assume the ring slipped out easily bc it was cold. The impeller looked good, you could tell that someone had pulled it out and just gently polished off the edges, probably to take some minor nicks out. I flipped the wear ring around and the impeller wouldn't rotate in there, the fit was just that tight.

    2nd machine -
    new solos 14/19 impellor, that and the wear ring looked perfect. I did notice in the tunnel housing right before the impellor that someone had dremeled off the fins that direct water towards the impeller... not sure if this is some sort of mod. Also the area in general where those fins used to be was roughly dremeled... bad job if you ask me, not smooth at all. I'll probably put some sand paper on my die grinder and smooth it out lightly.

    When I reassemble everything,
    1. is there some sort of silicone I should install inbetween the impeller housing and the ski?
    2. paste i should put on the outside of the wear ring so i doesnt rotate with the impeller?
    3. also red loctite on all the removed bolts right?


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    They dremeled off the fins because one or more was broken off - no problem. It's all of nothing with the fins... Ron

  3. #3
    2x 2004 Seadoo RXP. Milwaukee, Wisconsin. wisconsin_quat's Avatar
    Join Date
    Mar 2009
    Posts
    144
    can anyone confirm that there is no silicone required when reinstalling the pump / wear ring?

    also any paste or glue required around the wear ring so it doesn't spin in place?

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by wisconsin_quat View Post
    can anyone confirm that there is no silicone required when reinstalling the pump / wear ring?

    Confirmed....

    also any paste or glue required around the wear ring so it doesn't spin in place?

    Nope..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 25
    Last Post: 04-08-2009, 04:50 AM
  2. can't get my wear ring out!!!!
    By FL03GTX in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-26-2007, 09:49 PM
  3. Those Going to MUDBUG:: In Need of RXP Wear Ring.....!!!!!
    By VFX_Artist in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-07-2006, 07:40 PM
  4. I just want to flip my wear ring what tools do I need?
    By TroyRXP15 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-30-2006, 09:10 AM
  5. Do i need to cahnge my wear ring?
    By Totallyblown in forum 4-Tec Performance
    Replies: 1
    Last Post: 11-21-2005, 05:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •