Results 1 to 6 of 6
  1. #1
    Trigger's Avatar
    Join Date
    Jun 2008
    Location
    Cape Coral, FL
    Posts
    158

    Switched to UNI filter IDLE HIGH

    Ok i switched to a UNI filter and now my ski is running fast idle when not in the water not like it was before and when i rev it up it throttles down very slow how to i sort this?


  2. #2
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    Installing the Uni filter should not change the idle.....1200 rpm +/- 100. Better check the vacuum lines near the t-fitting from the turbo.

  3. #3
    supermac's Avatar
    Join Date
    Dec 2005
    Location
    Mooresville, NC
    Posts
    406
    +1
    10
    The issue ended up being his throttle cable.. something got tweaked during install and he had to re-adjust it to let the throttle body fully close.

  4. #4
    Trigger's Avatar
    Join Date
    Jun 2008
    Location
    Cape Coral, FL
    Posts
    158
    Quote Originally Posted by supermac View Post
    The issue ended up being his throttle cable.. something got tweaked during install and he had to re-adjust it to let the throttle body fully close.
    yes that was it i have my ski running great now...im not sure what changed but i must have bumped something anyway everything came out ok i should have posted something!

  5. #5
    BLAKE 01 WS6's Avatar
    Join Date
    May 2008
    Location
    Houston, TX
    Posts
    8
    did you notice any performance gains?

  6. #6
    Trigger's Avatar
    Join Date
    Jun 2008
    Location
    Cape Coral, FL
    Posts
    158
    Quote Originally Posted by BLAKE 01 WS6 View Post
    did you notice any performance gains?
    yes especially out of the pocket

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What year did BRP switch to metal oil filter caps?
    By Ferrari Steve in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-03-2013, 09:11 AM
  2. 97 Wave Venture Idling High after Switching To Pre Mix!!
    By Scobee1kenobi in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-17-2012, 06:34 PM
  3. switched to open loop cooling on my SC 4-tec XPL
    By rapidacceleration in forum Conversion PWC Performance Skis
    Replies: 27
    Last Post: 04-12-2010, 09:29 PM
  4. Switched to the dark side
    By red rider in forum Yamaha PWC Performance (2-stroke)
    Replies: 24
    Last Post: 12-22-2006, 07:40 PM
  5. What gains switching to a Vortex Impeller on my RXT?
    By scooby-rxp-doo in forum 4-Tec Performance
    Replies: 14
    Last Post: 02-17-2006, 03:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •