Results 1 to 8 of 8
  1. #1
    big83bronco's Avatar
    Join Date
    May 2006
    Location
    Macon, GA
    Posts
    326

    Cracked Pump shoe area!!!!!

    After removing the ride plate the pump shoe dropped off pretty bad. The bottom side of teh hull is cracked out on teh mounts! How do I fix this????? PLEASE HELP!!!!!!!


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    535
    If it is a 03 the dealer will fix it under warranty

  3. #3
    big83bronco's Avatar
    Join Date
    May 2006
    Location
    Macon, GA
    Posts
    326
    Nope...its an 01....these should be recalled!!!!

  4. #4
    big83bronco's Avatar
    Join Date
    May 2006
    Location
    Macon, GA
    Posts
    326
    How do I fix this. I was thinking of just epoxying the pices back in then lay fiberglass on teh inside then make a new mounting plate out of some stainless plate w/ holes drilled in it and use some new stainless bolts to run through it all to sandwich it all together. Will this work?

  5. #5
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    535
    that will work, Make sure the plates are big enough so you will support all the area.

  6. #6
    Mr Bill's Avatar
    Join Date
    Aug 2005
    Location
    Macon Georgia
    Posts
    451
    Tim,

    Can you post some pics?? Give me a call tomorrow. 478-714-8255.

  7. #7
    spud's Avatar
    Join Date
    Jul 2006
    Location
    Oceanside, California
    Posts
    1,347
    +1
    2
    R&D makes a pump tunnel repair kit. Get the new 05 inserts with it. Get some 5200 adhesive. Then its a lot of work but worth it. Here are the steps.


    1. Remove bolts from pump shoe

    2. in your case remove pump shoe. If the pump tunnel didn't fail leave the shoe in

    3. remove battery box and all hoses that will be in the way.

    4. use a putty knife and get those globs of adhesive stuff out of there (this is the worst part).

    5. use a dremel and sand the areas the old inserts set in smooth

    6. sand the excess adhesive off the tunnel close to the waterbox strap retainer.

    7. sand the ramp that leads to the water box retainer smooth

    8. prefit the tunnel (you will do this 3 or 4 times) and sand clearances for hoses etc.

    9.once the tunnel has been prefitted and all fittings clear. press the reinforcement piece firmly into place. I used a great big pry bar and pressed it down and back until it was tight.

    10. climb under the ski with a properly sized drill bit and drill out the holes from underneath. If you use a light touch the reinforcement wont move.

    11. after it is drilled remove the reinforcement and fit the new inserts to it. You will have to open the holes in the reinforcment to accept the inserts. you will also need to file, or grind the inserts to fit on the reinforcement

    12 place the reinforcement back into the hull. Properly locate it. Put 5200 on the inserts. Be careful not to get it into the threads.

    13. place the inserts and pull them down tight with the bolts

    14. allow to cure over night

    15 remove reinforcemnt assembly and sand and clean all mating surfaces.

    16 Spread 5200 around the insert and on the tunnel. No without making too big of a mess relocate the reinforcement and bolt it in place. Get her tight. I had to use Q-Tips to clean the holes so I could get the bolts started.

    Don't try to clean the 5200 up in th hll that squeezed out it gets really messy and looks worse. Clean any on the outside of the hull though.

    This is a bitch. It takes a long time it is dirty and dusty. But I believe this to be the best repair. I did it ti both of my skis
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	dsc01149_940.jpg 
Views:	64 
Size:	1.33 MB 
ID:	5927   Click image for larger version. 

Name:	dsc01149_920.jpg 
Views:	61 
Size:	668.7 KB 
ID:	5928  

  8. #8

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    buy the mounts for an 05, they are 2 in 1 and just marine-tex in. Do the pump tunnel mod and glass the mounts, just make sure the shoe fits up in the hull right. The rideplate mounts are the same way

    Mike

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Seal intake pump shoe area
    By Wan2Live in forum Sea Doo Spark
    Replies: 3
    Last Post: 07-12-2014, 12:22 AM
  2. pump shoe mounting surface cracks!
    By dhoad in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 09-06-2007, 03:11 PM
  3. If your pump shoe cracks...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 11-04-2006, 03:13 PM
  4. Cracked Pump Shoe-need Advice!!
    By HIGHLAND LAKE BOYS in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-24-2006, 10:14 PM
  5. 05 with cracked pump shoe
    By mikel70 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 03-18-2006, 09:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •