Results 1 to 5 of 5
  1. #1
    stangbang's Avatar
    Join Date
    Oct 2007
    Location
    West Palm Beach
    Posts
    844
    +1
    129

    Do these numbers seem ok?

    I just added the r&d plate, 6 degree timing, lx wedge, 2nd water box removal, dbi intercooler mod and removed the back 2 vent hoses and I only topped out at 69 on gps. I was pretty much hoping for 70 to 71. It was a bit humid out, but I was also down to 8 - 10 gal. of fuel. RPM's were in the 7900's.

    I also found a bunch of sand in my stock rideplate when I removed it. I'm wondering if I'm having pump/impellar issues.



  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    What was your speed prior to the Mods?

  3. #3
    stangbang's Avatar
    Join Date
    Oct 2007
    Location
    West Palm Beach
    Posts
    844
    +1
    129
    Not sure. I didn't have a gps last fall. My buddy with a 67 mph sho ran side by side with me, so I would guess between 66 and 67.

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Quote Originally Posted by stangbang View Post
    I just added the r&d plate, 6 degree timing, lx wedge, 2nd water box removal, dbi intercooler mod and removed the back 2 vent hoses and I only topped out at 69 on gps. I was pretty much hoping for 70 to 71. It was a bit humid out, but I was also down to 8 - 10 gal. of fuel. RPM's were in the 7900's.

    I also found a bunch of sand in my stock rideplate when I removed it. I'm wondering if I'm having pump/impellar issues.


    most likely normal thats where i'm at with stock modified grate and plate.

  5. #5
    Hooah_Killer's Avatar
    Join Date
    Sep 2008
    Location
    Midwest
    Posts
    412
    i think its because youre at the rich end of the lake and cant find any smooth water to run your ski in..hahahahaha

    well youve done the mods exactly what i am having bridgeport do (plus the ocms as a the 08 and the bov and emission by pass), the only real difference is i am having impros tweek the impeller for some mph gain...it will be interesting to see what i get since we both have 07's

    if i get 70ish i will be happy but i have glass water (and logs) at my end
    Last edited by Hooah_Killer; 04-20-2009 at 12:01 PM. Reason: added stuff

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What do these pitch numbers really mean?
    By jpa1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 57
    Last Post: 04-22-2014, 08:26 PM
  2. Do These Numbers Sound Good For A Stock S150 SCIC?
    By duramaxxed in forum Sea Doo Sport Boats
    Replies: 9
    Last Post: 07-21-2008, 04:36 PM
  3. Do These Numbers Sound About rite?
    By holdnon72 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-01-2007, 05:36 PM
  4. What do these numbers represent
    By Red Devil in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-13-2007, 11:27 PM
  5. Do these numbers seem right?
    By North49 in forum 4-Tec Performance
    Replies: 11
    Last Post: 11-06-2006, 12:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •