Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11

    Hydrolocked my RXP

    So I was out today riding and did a sub on the ski and it injested water within 5 seconds the motor died. Now it wont turn over at all. I pulled the intake hose off the supercharger and water came out of it. I pulled the plugs and the rear cylinder has a little water in it. I dont know why the motor wont turn over. Anyone got any ideas?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,994
    +1
    1,903
    It wont turn over even with the plugs out? If not you may have bent a rod

    Must have been some sub!

  3. #3
    Damn, that's a pretty good trick. Was it repeated subs? or just one?

    I've done some KILLER subs (ALL THE WAY UNDER) on my RXP and came out relatively dry.

    Did you have your storage bin in? My hood doesn't seal up that well without.

  4. #4
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Yeah I pulled the plugs out and the rear plug was a bit wet... checked the piston had some water on top of the piston. I have a PPG stage 1 on it. It was actually not a really deep sub... I dunno how so much water got into it.

  5. #5
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Oh and I pulled the intake hose off the supercharger and about 1 pint of water came out of the hose.

  6. #6
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Lets say its a bent rod... if I have an auto mechanic work on it.. do you think he could fix it or do I need someone with 4-tec knowledge fix it?

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,994
    +1
    1,903
    Will the engine spin over with the plugs out?

  8. #8
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    No it wont spin over with the plugs out.

  9. #9
    oh boy, I fear the worst my friend. May have bent/broke a rod.

    Have you checked all the fuses and such just to make sure?

  10. #10
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    no did not check the fuses... when i push the start button it just clicks... i cant believe i bent a rod just from water... i got water in my xp lots of times and i just pumped it out dried the spark plugs and was out riding again.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What not to do with your RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 60
    Last Post: 01-14-2010, 10:20 PM
  2. RXP Zip Ties
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 28
    Last Post: 06-28-2007, 12:00 AM
  3. RXP MYTHS !!!!!!!!!!!
    By CRAZEDRXP in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 08-11-2006, 06:16 PM
  4. How bad is you RXP ? ? ? ? ?
    By Jrsrxp in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 06-07-2005, 07:50 PM
  5. sound improvment (louder) on RXP ?
    By mrracing in forum 4-Tec Performance
    Replies: 23
    Last Post: 05-05-2005, 05:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •