Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1

    Old or new model stator ?

    Hi guys,
    Im currently rebuilding my SL1050, and was wundering if I have the new model stator. Can some of you guys help me determine which model it is ?





    Best regards,
    Jesper, Denmark


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    What is the part number on the CDI module in the electrical box?

    Normally an updated stator would be matched with an updated CDI part number.

    Is there a part number marking or label anywhere on the stator, or the stator cable?

    What year is your SL 1050?

  3. #3
    K447: Here's the pictures of the Electrical box. Its a 1997 as far as I know.






    Jesper, Denmark
    Last edited by Syswatch; 04-20-2009 at 11:08 AM. Reason: missing year

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    What are the last two digits of the HIN number plate on the rear deck?

    4010885 doesn't show up in the Polaris parts cross reference, and there isn't even a model listing for INTL (International) SL 1050 in 1997

    The ignition coil pack 4060153 was used 1996 - 1998

  5. #5
    K447: Its an old lady...


  6. #6
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    The 4010885 number doesn't show up in the PVL update parts list either...so I would guess it's not the updated version.

  7. #7
    Hmm, strange... I will have to see if it will start when I have rebuild the engine.
    Otherwise, is it possible to buy a new CDI box ?

    Jesper

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    L697 means it was manufactured in December 1996, as a 1997 model
    Quote Originally Posted by Syswatch View Post
    K447: Its an old lady...


  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by Syswatch View Post
    ... I will have to see if it will start when I have rebuilt the engine.
    Otherwise, is it possible to buy a new CDI box ?...
    Do you have a reason to think the existing CDI or stator are bad?

    If either one is bad, then you are best to purchase the PVL Ignition System Update Kit, PN 2873091 (1996-1998 900 & 1050 engines)
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Polaris PVL Update Kits (1997-1999)_001.jpg 
Views:	4628 
Size:	69.6 KB 
ID:	127088  

  10. #10
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    34
    That is deffinetly the updated stator.(It has 3 aluminum fingers,that are not covered with windings) The original design will have all fingers covered with windings.

    The CDI that comes in the update kit has the part number 4010885 crossed off, and part number 4010447 written in yellow paint marker.

    I think you will be fine.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Owners of 2015 Yamaha FX / FZ SVHO......Any complaints or issues with the new model?
    By AlabamaPWC in forum Yamaha PWC Performance (4-stroke)
    Replies: 46
    Last Post: 07-07-2016, 09:12 PM
  2. Old or New
    By dowrad in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-22-2011, 05:50 PM
  3. Repitch or new impeller?
    By 818RXP in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-01-2006, 12:25 PM
  4. Rotax Racing question about old RRECU & New SCer Impelle
    By Water4fire in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-20-2006, 11:41 AM
  5. Spark plugs... pictures of old and new, Normal?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-08-2005, 10:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •