Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Feb 2008
    Location
    No. MN
    Posts
    320

    MSX 140 - May Need New Stator

    Looking at the two threads going here, I am thinking my stator is BO. One thread is the one with "won't idle" as the by line. The other is the "140 saga" thread.

    Both have similar endings/advice BO stator. The question is:

    1.) Buy the one Randy has for sale on Ebay for $125.
    2.) Buy a Virage Stator like Photo has.

    Which is the correct Virage stator to look for? I am not going to do anything till Desperado (i think that is the guy) gets his EMM back fro DFI.

    Who is DFi and how can I get ahold of them?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276

    4010320

    Are you talking about using a Virage TX (carb), or Virage TXi stator?

    As far as I can tell, the same 4010320 stator was used in all Ficht engines, 1999-2004

    DFI Technologies contact info can be found here.

  3. #3

    Join Date
    Feb 2008
    Location
    No. MN
    Posts
    320
    Thats the question. PH2 says his 140 worked perfect after he put a virage stator in it.

  4. #4

    Join Date
    Feb 2008
    Location
    No. MN
    Posts
    320
    Will wait on "jeto", not Desparado.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by Koodat View Post
    ... PH2 says his 140 worked perfect after he put a Virage stator in it.
    If you are talking about his Matrix conversion, that MSX 140 was converted to a carbureted system, and the entire fuel injection system, including the stator, was swapped out for carb'ed Virage TX gear.

    During the course of the Matrix conversion, it was discovered that the bolts holding the Ficht stator in place were slightly too long, and were bottoming out in the mounting holes. IIRC, the result was the stator was not held firmly in place, and was shifting around as the engine ran, causing problems.

  6. #6

    Join Date
    Feb 2008
    Location
    No. MN
    Posts
    320
    Ah Ha. Then it is just a standerd replacement stator that I may need.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by Koodat View Post
    Ah Ha. Then it is just a standard replacement stator that I may need.
    Yes.

    Just check that the stator mounting bolts are actually clamping properly, and not bottoming out in their threaded holes.

  8. #8

    Join Date
    Feb 2008
    Location
    No. MN
    Posts
    320
    I cut the stator bolts when I initially re-built the motor last year, so I should be good to go, but will re-check after my diagnostics in a few weeks and the too anticipated removal of the motor "again".

  9. #9
    Jeto
    Join Date
    Aug 2008
    Location
    Edmonton, Alberta
    Posts
    35
    I have not heard from DFI yet - hopefully this week. if it comes back clean then the stator will be changed for me as well.

    Does the motor have to come out to change the stator or can it be done in palce by moving the gas tank?

    Anybody now where I can locate a stator?

  10. #10

    Join Date
    Feb 2008
    Location
    No. MN
    Posts
    320
    Randy has one on Ebay. There was another there as well, but for like $400.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help MSX 140 pics needed
    By 785 lugs in forum MSX/Matrix
    Replies: 4
    Last Post: 08-31-2015, 04:14 PM
  2. MSX 140 Computer Needs Fixed
    By dcspankie33 in forum MSX/Matrix
    Replies: 8
    Last Post: 11-30-2014, 11:19 AM
  3. Msx 140 Cylinder needed.
    By Scarab28 in forum MSX/Matrix
    Replies: 1
    Last Post: 07-13-2014, 10:24 PM
  4. WTB - Parts Feeler: 2004 msx 140 steering cable new or used
    By Makon in forum Polaris Classifieds
    Replies: 2
    Last Post: 05-19-2014, 08:20 PM
  5. 2003 polaris MSX 140 problem - need help
    By orrjoe in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-25-2007, 01:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •