Results 1 to 8 of 8
  1. #1
    abarrassr07's Avatar
    Join Date
    Aug 2008
    Location
    Louisiana
    Posts
    424

    is this 04 rxp worth $2000

    i dont have pictures of it but i went to the dealer and some guy had a 04 rxp he was fed up spending money on trying to fix, engine has about 170 hours, inside looked clean, but outside the haul is in rough condition, has about a 6 inch spider crack on the side where the numbers go. the bottom has some 1inch diameter gouges to the fiberglass, didnt cut into it but looks like the paint and gelcoat just washed away. the only thing wrong with it is that the battery wont stay charged. when he goes out it runs fine for hours then the next hour he goes to crank it up and battery is dead. any thoughts? the dealer said its more than likely the ecu. i think he said it may have been jump started previously, not too sure on that. is there a way to fix the spider crack, its just in one section.


  2. #2
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    spider cracks are usually just in the gel coat. either sand off all the gel coat and re-apply or if its got into the fiberglass, you have to grind into the crack and then fill with fiberglass or filler, then sand and paint. pretty easy!!

  3. #3
    Brian bconwayls1's Avatar
    Join Date
    Jan 2007
    Location
    St. Louis
    Posts
    402
    I would inspect the bottom for any damage that would lead to this...

    http://www.greenhulk.net/forums/show...t=delaminating

    If it runs, I would first be looking at the rectifier for charging problems.

  4. #4
    State of Confusion BartenderSmalley's Avatar
    Join Date
    Jul 2008
    Location
    Wellington, Florida
    Posts
    658
    Quote Originally Posted by abarrassr07 View Post
    i dont have pictures of it but i went to the dealer and some guy had a 04 rxp he was fed up spending money on trying to fix, engine has about 170 hours, inside looked clean, but outside the haul is in rough condition, has about a 6 inch spider crack on the side where the numbers go. the bottom has some 1inch diameter gouges to the fiberglass, didnt cut into it but looks like the paint and gelcoat just washed away. the only thing wrong with it is that the battery wont stay charged. when he goes out it runs fine for hours then the next hour he goes to crank it up and battery is dead. any thoughts? the dealer said its more than likely the ecu. i think he said it may have been jump started previously, not too sure on that. is there a way to fix the spider crack, its just in one section.
    Where is it located??

    On the battery issue - there are two possible things to look for, if I remember this correctly. One is called the 'stator' which I believe is located in the engine and I believe it is what generates the actual current that is supposed to keep the battery charged while the ski is running (think of if like an alternator in a car...once the car is started you could disconnect the battery and run it off the alternator) and the other is the voltage regulator - which I believe is located in the front of the ski right near the fuel tank. It looks like a very small radiator coil....smooth on one side, 'waffled' fins on the other for cooling. This diverts the charge to the different areas of the ski that need power to operate, to include sending a small amount of current BACK to the battery to keep it charged. Mine failed on my '04 GTX recently so I swapped it out. I still have the old one so I can post a picture of it if necessary...and I THINK I have the stator (I believe its called a magneto...I might be confusing a couple different parts..sorry) so I can post that up as well.

    Let me look for the previous thread...someone explained it VERY well to me...told me exactly what to test and where to find out the current, etc. I will find it and come back shortly.

  5. #5
    State of Confusion BartenderSmalley's Avatar
    Join Date
    Jul 2008
    Location
    Wellington, Florida
    Posts
    658
    Quote Originally Posted by abarrassr07 View Post
    i dont have pictures of it but i went to the dealer and some guy had a 04 rxp he was fed up spending money on trying to fix, engine has about 170 hours, inside looked clean, but outside the haul is in rough condition, has about a 6 inch spider crack on the side where the numbers go. the bottom has some 1inch diameter gouges to the fiberglass, didnt cut into it but looks like the paint and gelcoat just washed away. the only thing wrong with it is that the battery wont stay charged. when he goes out it runs fine for hours then the next hour he goes to crank it up and battery is dead. any thoughts? the dealer said its more than likely the ecu. i think he said it may have been jump started previously, not too sure on that. is there a way to fix the spider crack, its just in one section.
    Found it....check out this thread...then do a search for "stator" and you will come up with a few others.
    http://greenhulk.net/forums/showthre...ghlight=stator

    Answer to your question...170 hours is a lot, but only if the ski has been abused. Sounds like the hull has taken a beating so most likely the engine has as well. Salt or fresh water?? Look in the intake if you can and see if there is residue there...... if the engine is running well, check to see if there have every been SC failures (washers) and what was done about it. If the SC hasn't been upgraded, plan on at LEAST $300 for labor and the entire rebuild kit - recommended at 100 hours. For $2000, the 215HP motor is a great buy....there are always parts on the hull that could be 'swapped' out with others so there is value there as well.

    I was actually considering trying to find a wrecked RXP or RXT just to get the 215hp motor out of it and put it into my GTX.

  6. #6
    State of Confusion BartenderSmalley's Avatar
    Join Date
    Jul 2008
    Location
    Wellington, Florida
    Posts
    658
    Quote Originally Posted by abarrassr07 View Post
    i dont have pictures of it but i went to the dealer and some guy had a 04 rxp he was fed up spending money on trying to fix, engine has about 170 hours, inside looked clean, but outside the haul is in rough condition, has about a 6 inch spider crack on the side where the numbers go. the bottom has some 1inch diameter gouges to the fiberglass, didnt cut into it but looks like the paint and gelcoat just washed away. the only thing wrong with it is that the battery wont stay charged. when he goes out it runs fine for hours then the next hour he goes to crank it up and battery is dead. any thoughts? the dealer said its more than likely the ecu. i think he said it may have been jump started previously, not too sure on that. is there a way to fix the spider crack, its just in one section.

    Sorry, don't mean to hijack your thread....look at this one...this is good info:

    http://greenhulk.net/forums/showthre...ghlight=stator

  7. #7
    abarrassr07's Avatar
    Join Date
    Aug 2008
    Location
    Louisiana
    Posts
    424
    thanks for the help guys, i talked to the guy today, said sc has never been touched!? never had any faliures with it, dealer thought it was the voltage reg, so changed it, was not a salt water ski, and didnt notice any corrosion on it, if the stator is similar to that of a 2 stroke ski im familiar somewhat with them, this is going to be my first 4tec project, the ski is located in Mc Louisiana where i am at. as far as the super charger since ive never messed with them before, ill probably give jerry a call and drop it off wont have to wait long to get it back since its only a few minutes away. Just an update, the guy said that the ski rill runs flawlessly for an hour and then all of a sudden kill and not start up again. so he charged it up again, took it out, it would run good and then die while on top. then he said he had trouble getting it to start after that, so the dealer seemed to think it was the fuel pump as well, changed it and still nothing, so i guess ill have to just try it out for myself and see if its a charging issue, fuel issue, or both, engine is in great condition and inside is not any dirtier than an 04 should be.

  8. #8
    Brian bconwayls1's Avatar
    Join Date
    Jan 2007
    Location
    St. Louis
    Posts
    402
    Although not a 100% guarantee, have them show you the service history. A dealer once told me everything was fine with a ski, and was proved wrong by the history. It even said they ONLY replaced s/c only after it failed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. is this 04 rxp worth $2000
    By abarrassr07 in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-21-2009, 09:07 AM
  2. How much is this '05 RXP worth? (28 hours)
    By Stuff in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-17-2008, 09:46 PM
  3. Is a 05 RXP worth $6000?
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 01-15-2008, 08:17 PM
  4. Is a New RXP worth the investment?
    By Agent22vicious in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 06-29-2007, 07:14 AM
  5. What is an 04 RXP worth on the open market?
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-08-2006, 08:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •