Results 1 to 9 of 9
  1. #1
    homebrew's Avatar
    Join Date
    Aug 2008
    Location
    Hampton Va.
    Posts
    556

    need some help with the riva free flow kit

    i need help with the riva free flow exhaust kit i just put on -- i have a 2007 gtx limited -- i did as the instruction sheet had said -- removed the baffle etc.... put the free flow pipe in as directed -- and it didn't fit very well had to do some stretching of the elbow rubber joint going out of the hull -- went out to ride today and once i went into a plane the exhaust warning sound came on -- so i turned around and just made it to the boat ramp and got it back on the trailer -- the ski was half full of water --the exhaust pipe came out of the rubber elbow ( and it was clamped on tight ) when i installed it i wasn't to happy with how bad it fit ( i should have listened to my gut ) is there a adapter that goes between the rubber elbow to the exhaust pipe ? or did i by some chance recieve the wrong one ? i called riva but i only get a recording -- and help would be great


  2. #2
    homebrew's Avatar
    Join Date
    Aug 2008
    Location
    Hampton Va.
    Posts
    556
    well just got back in from flushing out the engine area and fogging it all due to salt water ( plus got the water out so i can see better ) it turns out the input hose from the stern to the greco filter for the intercooler came off-- the free flow exhaust pipe is still connected ( i still don't like how it fit ) so that better explains why the exhaust temp beeper was going off and why the ski filled up so fast -- goes to show always double check all your connections before putting your ski in the water

  3. #3
    Chaserxp215's Avatar
    Join Date
    May 2008
    Location
    Grosse Pointe, MI
    Posts
    943
    How did you like the sound, I was thinking about getting one.

  4. #4
    jmatherne18's Avatar
    Join Date
    May 2008
    Location
    new orleans
    Posts
    81

    Talking

    I. Just installed the free flow on my p-x and it fit really tight also as long as you got the clamps tight you shouldn't have a problem as for the sound personally I like it not to loud but gives it some tone

  5. #5
    homebrew's Avatar
    Join Date
    Aug 2008
    Location
    Hampton Va.
    Posts
    556
    the sound suprised me -- sounded good -- but it was a bit louder then norm. due to no water going through the waterbox to help muffle it --i think you will like it if you get it -- to early for me to really give a verdict -- i got to go back out and try again now that i have the "leak" fixed ( more like a fire hydrant when the interloop hose comes off )

  6. #6
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    That same thing with the IC hose happened to me. Except the line on my RXP split. I ingested water and luckily the engine is still running strong a year later. You better make sure no water is in your engine!

  7. #7
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Location
    Jacksonville, N.C.
    Posts
    2,214
    +1
    2
    It sounds best at idle and low rpm. It sounds even better with no water flow. But not as good as a thru hull with a performance waterbox.

  8. #8
    canadianRxtX's Avatar
    Join Date
    Mar 2009
    Location
    Southern Ontario
    Posts
    364
    Quote Originally Posted by Chaserxp215 View Post
    How did you like the sound, I was thinking about getting one.
    I just put one on my RXTX last weekend and i love the way it sounds. It totally kicks ass. For a relatively cheap and easy mod... ie. not having to swap out the waterbox, this free flow kicks ass!!! i 150% recommend it. Its not usper loud but lots more tone. compare it to putting a magnaflow on a v8 pickup

  9. #9
    Be a Hero...Punch a Koala Kaotic's Avatar
    Join Date
    Aug 2008
    Location
    Evansville, IN
    Posts
    534
    I love the way mine sounds. here's a video of it out of water.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some help with the Vtech Guru's
    By Slow 91 in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-08-2015, 11:18 PM
  2. Need some help with a 650 LX
    By utahnewbie in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 05-04-2007, 11:59 PM
  3. need some help from the US guys
    By winterstick in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-28-2007, 09:47 PM
  4. I Need Some Help With My Shark !!!!!!
    By sleblanc in forum Polaris Open Discussion
    Replies: 9
    Last Post: 12-20-2006, 03:17 PM
  5. Need some help with adjust a thrust
    By AaronC in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-10-2006, 06:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •