Results 1 to 5 of 5
  1. #1
    Banned User
    Join Date
    Jun 2008
    Location
    kingwood,texas
    Posts
    526
    +1
    1

    stx 15f at 70 mph?

    has any one got there 15f this fast with just motor and no supercharger?


  2. #2
    AaronC's Avatar
    Join Date
    Aug 2006
    Location
    Sacramento, CA
    Posts
    457
    +1
    4
    Riva sold a kit with high compression pistons and cams. That setup will run 70mph+ but it won't with just the riva RPM kit. The fastest my RPM setup ever went was 66.6 and that was only on a couple of days. It usually avg'd 65.7-66.1. Some have hit 68 but I don't see it happening consistently like these supercharged ski's do.

    I wanted to add the extrude honed exhaust manifold and modify the waterbox. Maccracing said 8 hp from the manifold so I bet you can consistently get 68 with that added to the RPM kit. Maybe flirt 69-70 on an optimal day.

  3. #3
    YAMAPRO's Avatar
    Join Date
    Nov 2006
    Location
    State of Mississippi
    Posts
    416
    I had a 15F practice boat a few years back and it would do a consistent 68mph every pass. It had the pipe work, pistons, CDI, cams, skat pump, skat nozzle, carbon seat etc.

  4. #4
    Banned User
    Join Date
    Jun 2008
    Location
    kingwood,texas
    Posts
    526
    +1
    1

    speed?

    well i was thinking about endurance kit with out pistons.
    just cams and ecu? i dont wanna run race gas.
    i have a 2008 sho yamaha and i want this 15f to at least hang with it.

  5. #5
    YAMAPRO's Avatar
    Join Date
    Nov 2006
    Location
    State of Mississippi
    Posts
    416
    yea, I was running race fuel. It was a strong ski though you could hold 68mph around an entire bouy coarse and it looked like it was really movin.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What does it feel like to wipe out at 70 mph?
    By pyroseth in forum Kawasaki PWC Performance (4-stroke)
    Replies: 44
    Last Post: 05-25-2015, 03:06 PM
  2. 2004 STX 15F DO I NEED A NEW IMPELLER? look at picture.
    By 909STX15F in forum Kawasaki PWC Performance (4-stroke)
    Replies: 27
    Last Post: 04-19-2013, 11:26 PM
  3. Bolt/nut at bottom of 2010 stx-15f
    By andy8472 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 06-12-2011, 11:00 AM
  4. STX-15f losing MPH/RPMs POST RPM kit install
    By 07STX15 in forum Kawasaki How To & FAQs
    Replies: 6
    Last Post: 03-28-2011, 03:46 PM
  5. 04 STX 15F not running at peak RPM
    By bdl1801 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 07-20-2010, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •