Results 1 to 4 of 4
  1. #1

    785 Pro impeller fell off, need help

    As stated in another post I finally got my 97' 785 Pro running close to right the other day & after about 10 minutes it made some nasty clanging noises & wanted to lock up. After pulling the pump off the impeller had unscrewed from the shaft. No damage to shaft or threads, just banged the edge of empeller. I figure I will go back with some loctite this time (dont know who installed impeller before). My question is specific to the impeller spacer (#13 on propulsion schematic pT# 5134505), I do not have one. Did the 97's have this piece? I think it should be there because the seal #12 is a larger diameter than the shaft alone & will not come close to sealing. I guess it could have fallen off in the water when the impeller came off. Thanks for the help.

    Ryan


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Quote Originally Posted by yeehaa View Post
    As stated in another post I finally got my 97' 785 Pro running close to right the other day & after about 10 minutes it made some nasty clanging noises & wanted to lock up. After pulling the pump off the impeller had unscrewed from the shaft. No damage to shaft or threads, just banged the edge of empeller. I figure I will go back with some loctite this time (dont know who installed impeller before). My question is specific to the impeller spacer (#13 on propulsion schematic pT# 5134505), I do not have one. Did the 97's have this piece? I think it should be there because the seal #12 is a larger diameter than the shaft alone & will not come close to sealing. I guess it could have fallen off in the water when the impeller came off. Thanks for the help.

    Ryan
    yes there should be a spacer that slips over the shaft and into the seals .

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Yep

  4. #4
    Looks like last installer forgot that part. On order.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB riva pro opas block off needed asap
    By bksbigboy69 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-23-2011, 08:34 PM
  2. Need help with SLX 785 Pro
    By jcjw1998 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-19-2010, 08:48 PM
  3. Need Help: 2000 785 PRO No Spark
    By mccann316 in forum Polaris Open Discussion
    Replies: 24
    Last Post: 05-05-2010, 09:32 PM
  4. 785 pro, need help with carb tuning
    By billybobtucson in forum Polaris PWC Performance
    Replies: 12
    Last Post: 10-01-2009, 01:21 PM
  5. need help for tuning pro 785
    By pro145hp in forum Polaris PWC Performance
    Replies: 7
    Last Post: 04-07-2007, 05:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •