Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Question Polaris SLX 780 Heads Up Display Problems

    I took the SLX to the lake yesterday, I had two problems with it. Almost none of the electronics work, MPH, Fule level, Oil level, Battery volts. The only things that worked were the clock and the RPM. What could be causing this?

    The other was it wont idle, it idle's for a few seconds but then dies, It ran great as long as i gave it gas. The hoses are new filters are new, the fuel/water separator has been cleaned, the petcock has been cleaned. I also ran a fuel system cleaner through it as suggested by my local Polaris shop. Any suggestions?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Unplug the MFD, and leave it unplugged overnight. Then reconnect it.

    If that doesn't fix it, then reset the MFD.
    Instructions are posted, or have a look here.

    Have you cleaned the carburetors internally? Fuel system cleaner products won't clean the internal filters.

  3. #3
    I have not, I'll give both a try and let you know the results. Thank You!

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    The idle needs to be set in the water to 1250-1300 RPM. Usually around 2600 RPM when on the trailer.

    I'd try the reset function for the MFD.
    Last edited by xlint89; 04-26-2009 at 07:27 AM.

  5. #5
    how do I adjust the idle needle to the cretin RPM, is there a cretin number of turns out?

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by koryk View Post
    how do I adjust the idle needle to the certain RPM, is there a certain number of turns out?
    Quote Originally Posted by K447 View Post
    ...have a look here...
    Did you click the link above?

    The service manuals explain a lot

  7. #7
    I checked the manual as recommended. It says that if the power drops below 10.9 volts the speedometer and and distance shut off. It MFD flashes LOPR but the PWC runs fine for long periods of time, starts every time with no hesitation, I know there is not a power issue, how do I make the MFD read the voltage correctly? It is reading that the voltage is 0.2! I did not locate a reset sequence, but did leave it unplugged last night and there is no change. It also never turns off, I read in the manual that it is supposed to shut off after 5 min of no use.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by koryk View Post
    ...I know there is not a power issue, how do I make the MFD read the voltage correctly?

    It is reading that the voltage is 0.2!

    I did not locate a reset sequence,
    ...It also never turns off, I read in the manual that it is supposed to shut off after 5 min of no use.
    Here is the MFD reset info.

    When the MFD goes to sleep after five minutes, the clock and fuel+oil levels will continue to be displayed.

    You have checked battery voltage with the engine running?
    Is it about 14.5 volts?

  9. #9
    I have not checked it, but if it was .02v as the MDF displays it wouldnt even try to turn over. The battery is new as of last week so I know its good.

  10. #10
    I thought there was a reference on pwctoday about someone repairing these displays, but it's been years.. probably cheaper to replace.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with Polaris SLX 780 (95)
    By D.Asher79 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 07-05-2014, 05:48 PM
  2. polaris slx 780 problems.
    By dageoman88 in forum Polaris Open Discussion
    Replies: 20
    Last Post: 06-29-2014, 09:27 AM
  3. Replies: 12
    Last Post: 06-05-2011, 01:59 PM
  4. Polaris SLX 780 Digital Display not working.
    By cubajorge2008 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 05-23-2010, 09:07 AM
  5. 1996 Polaris SLX 780 breaking up at full load, hmmmm?!?!?
    By TechSLX in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-15-2008, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •