Results 1 to 7 of 7
  1. #1

    Will PV motors run w/o the PFD (gauges)

    I've got a set of GPRs (800s) - both have some water in the gauge set.
    Is the "brains" for the PV servo in the display? Any reason the ski won't run without the display?


  2. #2
    SkiSwede's Avatar
    Join Date
    Apr 2009
    Location
    Denver, NC
    Posts
    25
    The display has a security system that can prevent the ski from being started. I suspect that nonworking gauges would be troublesome. trace the start/stop wires from the switch and unplug them, then find the same plug on the ebox and plug it in directly there. This will bypass the gauges.

  3. #3
    Can you tell me more about the function of the sec system - does it need to be "set". I vaguely remember something similar on a GP1200 years ago.


    What about the PV servo? What controls it?

  4. #4
    SkiSwede's Avatar
    Join Date
    Apr 2009
    Location
    Denver, NC
    Posts
    25
    The display uses a 4 digit code, and the ski can be locked as a [poor] theft deterrent. To reset it, unplug the single-pin blue connector and enter a new code (don't remember the steps exactly).

    The PV servo, I don't know, but I don't believe its related to the display.

  5. #5
    Quote Originally Posted by SkiSwede View Post
    The display uses a 4 digit code, and the ski can be locked as a [poor] theft deterrent. To reset it, unplug the single-pin blue connector and enter a new code (don't remember the steps exactly).

    The PV servo, I don't know, but I don't believe its related to the display.

    If the skis were not locked, is this still an issue - or is this a simple start-cut circuit that would need to be by-passed.

    I took apart one of the MFDs last night, it was about 1/2 full of water - LCD shot. The circuits might be OK, assuming it wasn't salt and was never powered up while under water. Yamaha wants over $500 for a display.

  6. #6
    SkiSwede's Avatar
    Join Date
    Apr 2009
    Location
    Denver, NC
    Posts
    25
    Quote Originally Posted by dcg9381 View Post
    or is this a simple start-cut circuit that would need to be by-passed.
    I believe that is the case.

    I'm sure you can find them on ebay used, or maybe on here. Probably around $250 or so.

  7. #7
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    the gp's had the 4 digit code. Not the gpr. You need the gauge but there is a way to bypass I just cant remeber how I did it, Its been so long.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 08-27-2013, 12:29 PM
  2. *HELP* XLT1200 PV will not stay running
    By mlconcannon in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-25-2012, 11:11 PM
  3. How to run water through the motor while working on my ski??
    By kfaf in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 04-04-2012, 01:27 PM
  4. 2001 yam. GP 1200 PV will start and run great out of water,but BOGGS in the water!
    By motormadness in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-27-2011, 09:18 AM
  5. Will A Primer Kit Lean Out the Motor?
    By Danimal2k5 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 08-17-2009, 10:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •