Results 1 to 3 of 3
  1. #1

    2003 kawi zxi 1100

    I just boust bought a 2003 zxi 1100--it starts and runs fine on the trailer, but when I got to the water it would not rev up--upon inspection I found that the cv slides would not open ---so I manually opened them with a long thin rod and the engine reved up--what is supposed to make the cv slides open--is a vac. hole or something blocked?

    help please suncoastdeano

  2. #2
    SkiSwede's Avatar
    Join Date
    Apr 2009
    Denver, NC
    The slides are vacuum operated by carb circuitry. The holes are rather large and I don't imagine they could get blocked easily. Out of principle I recommend pulling the carbs and cleaning them.

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    League City, Texas
    welcome to the forum

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 kawi zxi 1100
    By nismax in forum Kawasaki PWC Performance (2-stroke)
    Replies: 9
    Last Post: 03-13-2013, 02:23 AM
  2. 2001-2003 zxi 1100 carburetor rack
    By netinman in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-01-2010, 04:35 PM
  3. Look at this stator kawi zxi 750 *damage*
    By TX21 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 03-19-2008, 07:43 AM
  4. zxi 1100
    By 67pt67 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 12
    Last Post: 01-09-2008, 07:11 PM
  5. Help needed on ZXI 1100
    By Turbo Todd in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-18-2005, 11:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts