Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    rxpxseadog's Avatar
    Join Date
    Sep 2008
    Location
    long way from home
    Posts
    490
    +1
    54

    Who Is Running an EGT or A/F or Fuel Pressure

    I am just curious what others have done to install these engine monitoring devices on their RXP/T or RXP/T-X.

    I have a boost gauge and a/f gauge, but I am curious what others have done with other engine monitoring devices.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	CIMG1335.JPG 
Views:	81 
Size:	1.45 MB 
ID:	128060  


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    I am running fuel pressure, boost, EGT and use LM-1 for AFR when tunning.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_3794.jpg 
Views:	70 
Size:	984.2 KB 
ID:	128061   Click image for larger version. 

Name:	IMG_3791.jpg 
Views:	71 
Size:	742.2 KB 
ID:	128062   Click image for larger version. 

Name:	IMG_3729.jpg 
Views:	63 
Size:	917.8 KB 
ID:	128063  

  3. #3
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    For you guys with J pipes, this is what you need.
    THanks Speed.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	bung.jpg 
Views:	119 
Size:	4.45 MB 
ID:	128069  

  4. #4
    rxpxseadog's Avatar
    Join Date
    Sep 2008
    Location
    long way from home
    Posts
    490
    +1
    54
    Quote Originally Posted by skoepp View Post
    I am running fuel pressure, boost, EGT and use LM-1 for AFR when tunning.
    Perfect, just what I wanted to see/know.

    It looks like you just tapped (no welding - my poor hobart) the R&D extender to run the egt.

    Is that an autometer mechanical egt?

  5. #5
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by rxpxseadog View Post
    Perfect, just what I wanted to see/know.

    It looks like you just tapped (no welding - my poor hobart) the R&D extender to run the egt.

    Yes it is just tapped, not welded.
    But it will have a bung very soon in place of the tap.

    Is that an autometer mechanical egt?



    All my guages are dynatune. I am really liking the EGT and fuel pressure. They are very acurate and easy to read.
    Once you get an EGT you will see how 12.0 AFR is not as safe as we think.

  6. #6
    rxpxseadog's Avatar
    Join Date
    Sep 2008
    Location
    long way from home
    Posts
    490
    +1
    54
    Quote Originally Posted by skoepp View Post
    [/color]


    All my guages are dynatune. I am really liking the EGT and fuel pressure. They are very acurate and easy to read.
    Once you get an EGT you will see how 12.0 AFR is not as safe as we think.
    I like the Dynatune kit as well.

    What A/F numbers are you finding safe? I just went back to my 50lb injectors b/c I was concerned that I would run too rich as it gets warmer and more humid. After running the 50s I think the 55s may be safer.

    In deciding what to do, I wanted to have as much info about how the engine is performing to help figure out what is safest.

  7. #7
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    I have boost pressure and fuel pressure, then use the LC1 for tuning. I know what my WOT fuel pressure needs to be at to run safe so I just keep an eye on that. R88

  8. #8
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    TTT

  9. #9
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    I have A/F LM1, Three EGT probes, Engine coolant temp, Boost gauge, Fuel pressure gauge.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	CIMG4669.JPG 
Views:	37 
Size:	1.37 MB 
ID:	128446   Click image for larger version. 

Name:	CIMG4352.JPG 
Views:	45 
Size:	1.30 MB 
ID:	128447  

  10. #10
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by skoepp View Post
    For you guys with J pipes, this is what you need.
    THanks Speed.
    No problem bro. I hope it works out for you.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Who is running 73mph or more with their 300X?
    By Phil in forum Kawasaki PWC Performance (4-stroke)
    Replies: 46
    Last Post: 07-28-2011, 11:59 PM
  2. Who here is running an RXT with open loop cooling?
    By Green Hulk in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-05-2009, 07:10 PM
  3. Who is running an Autronic??
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-28-2007, 06:37 PM
  4. Who is running with no trim tabs?
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 27
    Last Post: 02-16-2007, 08:31 PM
  5. anyone who is running a SS wear ring
    By seadoo02xp in forum 4-Tec Performance
    Replies: 18
    Last Post: 08-23-2005, 09:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •