Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    captain slow Turbo Retro's Avatar
    Join Date
    Jun 2007
    Location
    Australia - perth
    Posts
    1,679
    +1
    164

    prop confusion????

    hey guys... any ideas on this one???

    have a 07 RXT

    running a rude 1, external I/C rude RRFPR, 15/19 skat 3 blade..... loved the holeshot... its great.... but the 15/19 3 blade is flexing and chewing up my liner

    i was pulling 8160 RPM with the 3 blade.... put in a 15/22 4 blade and am now pulling about 7700 RPM @ WOT.. i know its pitched for the RXT-x with 85mm nozzle... and the 07 RXT's run 83mm... no vts, I was going to repitch the prop....

    is 15/20 the way to go?? thanks...


  2. #2
    rxtmike's Avatar
    Join Date
    Oct 2005
    Location
    edison n,j,
    Posts
    708
    +1
    10
    yes ,that s what i am running 15/20 4 blade

  3. #3

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    Quote Originally Posted by retro_racer View Post
    hey guys... any ideas on this one???

    have a 07 RXT

    running a rude 1, external I/C rude RRFPR, 15/19 skat 3 blade..... loved the holeshot... its great.... but the 15/19 3 blade is flexing and chewing up my liner

    i was pulling 8160 RPM with the 3 blade.... put in a 15/22 4 blade and am now pulling about 7700 RPM @ WOT.. i know its pitched for the RXT-x with 85mm nozzle... and the 07 RXT's run 83mm... no vts, I was going to repitch the prop....

    is 15/20 the way to go?? thanks...
    if you are after top end speed 4 blade is the one....but you have to much pitch so you need to decrease about 2 mm on the 4 blade...and change your wear ring if its chewed up.

  4. #4
    captain slow Turbo Retro's Avatar
    Join Date
    Jun 2007
    Location
    Australia - perth
    Posts
    1,679
    +1
    164
    i am not after top speed.. thats the problem.. i like the 15/19 3 blade.... i would rather keep it if it wasnt eating liners... why is it eating liners?? i have read somewhere where other people were having the same problems...

    will try the 4 blade with a 20 pitch on it.. thanks..

  5. #5

    Join Date
    Feb 2008
    Location
    Perth, Western Australia
    Posts
    227
    Retro I think u need to wind down the boots n turn up the neons

    You may be making too much torque for that 3 blade?

    Also did you check to see if you are getting 100% throttle with the new Riva trigger you got?

  6. #6
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by retro_racer View Post
    i am not after top speed.. thats the problem.. i like the 15/19 3 blade.... i would rather keep it if it wasnt eating liners... why is it eating liners?? i have read somewhere where other people were having the same problems...

    will try the 4 blade with a 20 pitch on it.. thanks..
    How many hours do you have on your pump bearings?

  7. #7
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,884
    +1
    496
    You need a solid front engine mount if you don't have one yet your power is causing to much flex in the driveline eating up your wear ring!

  8. #8
    Quote Originally Posted by oklagp1200r View Post
    You need a solid front engine mount if you don't have one yet your power is causing to much flex in the driveline eating up your wear ring!
    Right on! You need to align it after putting in the front motor mount and then your set!

  9. #9
    Wakeskate or Die!!! RobbieMWD's Avatar
    Join Date
    May 2008
    Location
    Burleson, TX.
    Posts
    375
    Quote Originally Posted by Muddy River View Post
    Right on! You need to align it after putting in the front motor mount and then your set!
    What is the most least expensive way to align the driveline and how difficult is it?

  10. #10
    Quote Originally Posted by RobbieMWD View Post
    What is the most least expensive way to align the driveline and how difficult is it?
    Get with someone who has a alignment tool or see if someone will lend it to ya! There are about 6 of them floating around my area alone. You also might want to use the drive shaft circlip remover to get the circlip out then pull the shaft and install the alignment tool.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. confuse of prop at my rxp 2008
    By abie_lah in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-20-2009, 09:31 AM
  2. Prop Confusion Please help
    By zerowake in forum 4-Tec Performance
    Replies: 13
    Last Post: 03-16-2009, 09:17 PM
  3. Confused about repitching/bending prop please help
    By Turbo Nick in forum 4-Tec Performance
    Replies: 16
    Last Post: 04-27-2008, 07:55 PM
  4. solas prop compared to stock repitched
    By nitro rxp in forum 4-Tec Performance
    Replies: 23
    Last Post: 12-17-2007, 10:31 AM
  5. 4-TEC props
    By Phil in forum 4-Tec Performance
    Replies: 51
    Last Post: 05-26-2005, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •