Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Sep 2007
    Location
    Byron, GA.
    Posts
    69

    roaring and vibration

    My 250x is roading and vibrating out of the hole. I did a search I geuss my pump bearings are gone. What are the chances that I hurt more than just the pump bearings. I didn't ride it no further than I had to to get back to the boat ramp. Everything seemed ok after it got on plane. Also where is the best place to get bearings to replace the old?


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,157
    +1
    598
    Quote Originally Posted by r103 View Post
    My 250x is roading and vibrating out of the hole. I did a search I geuss my pump bearings are gone. What are the chances that I hurt more than just the pump bearings. I didn't ride it no further than I had to to get back to the boat ramp. Everything seemed ok after it got on plane. Also where is the best place to get bearings to replace the old?
    check in your pump is there any crap caught in the tunnel/ prop??

    Waz

  3. #3
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Exactly.

    It could be a bottle top, or a small stick. Anything can cause cavitation. Crawl under there with a flashlight and a small mirror (with the ski off, of course) and look up inside the intake tract.

  4. #4

    Join Date
    Mar 2008
    Location
    mississippi
    Posts
    510
    +1
    1
    I had the same problem with my 15f. Although I couldn't find anything wrong, Iam suspecting that something got up into the impeller .. You might want to get a small inspection mirror and a good flash light. Look closely cause its going to be small and check between the blades in the impeller.
    I think whatever was in mine fell out on the way home. If you don't find anything It would be a good Idea to remove the ride plate and check up in the pump that way ... gives you better access. Good luck bro .. don't condem the bearings right off the bat, its probably something very simple.

  5. #5

    Join Date
    Sep 2007
    Location
    Byron, GA.
    Posts
    69
    Pulled pump, the impeller was messed up. It came right off the shaft, somehow it got loose. It has never been removed before. The bearings seem to be fine. Anyone got an impeller? I need one asap, going to PC Beach soon.

  6. #6
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,991
    +1
    455
    Quote Originally Posted by r103 View Post
    Pulled pump, the impeller was messed up. It came right off the shaft, somehow it got loose. It has never been removed before. The bearings seem to be fine. Anyone got an impeller? I need one asap, going to PC Beach soon.
    I got an oem one with the speed pitch from impros used. Its slightly chewed up, but itll work fine if you need to borrow it. BTW, the same crap happened to me as well. Found the prop just sitting inside the pump

  7. #7
    Rocket Power !!! Spin21's Avatar
    Join Date
    Mar 2009
    Posts
    215
    BLU,

    Totally off subject but im new to the forum. Question: How do you attach a quote from someone elses post onto your response??

  8. #8
    madtown_chris's Avatar
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    182
    Quote Originally Posted by Spin21 View Post
    BLU,

    Totally off subject but im new to the forum. Question: How do you attach a quote from someone elses post onto your response??
    Every post has a "quote" button, just hit that to reply...

  9. #9
    Rocket Power !!! Spin21's Avatar
    Join Date
    Mar 2009
    Posts
    215
    Quote Originally Posted by madtown_chris View Post
    Every post has a "quote" button, just hit that to reply...
    Thanks Chris!!

  10. #10

    Join Date
    Sep 2007
    Location
    Byron, GA.
    Posts
    69
    Thanks guys, got one on the way from Jwillson. I hope to have it back togather today. Is there a how to on bearing removal?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. noise from pump area and vibration
    By kawaka in forum Kawasaki How To & FAQs
    Replies: 12
    Last Post: 10-18-2015, 04:43 PM
  2. Replies: 1
    Last Post: 06-16-2014, 12:50 PM
  3. RXT-X 2008 partial power loss and vibration
    By carteknik in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-16-2013, 06:01 AM
  4. 2006rxp Sudden Loss of power and vibration
    By filterthis2008 in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-08-2008, 08:03 PM
  5. spark plugs and vibrations on 93 SL 750
    By jmule98 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 08-27-2007, 11:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •