Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1

    94 750slt new fuel pump no pressure

    Hello, I just put in a new piston in my 750SLT and upgraded the fuel pump to the mukini triple outlet. I took it to the lake today and it would not run faster than 25 with the choke out, a few minutes later it died and would not restart. I took it home splashed some fuel in the carbs and it will run until it uses what I put in the carbs. I pulled the pulse line and it seems to have good pressure but its blowing out gas??? Do I have a defective fuel pump???


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Double check the connections you made to the pump fittings.

    Is it possible one or more are swapped around from where they should be?

  3. #3
    Everything seems tight, no leaks from the pump at the connections. I have the pulse line going to the middle portion fitting and the feed line going to the right place I think?? do the feed lines to the carbs make a difference if not in some certain order??

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Did you replace the fuel hoses too? If so, did you re-install the restrictor in the return hose?

    Where did you mount the new fuel pump? Is it mounted below the pulse fitting?

    If there's gas inside the pulse line, then the diaphragm may be damaged or full of gas. You may need to open the fuel pump up.

    Why is there gas in the pulse line? Is a needle stuck open? Maybe a gas tank vent stuck closed?

    Verify your connections are properly made.

  5. #5
    Thanks, for the help. I did replace the feed fuel lines and used the same return line, the restrictor is still in the line. I mounted the fuel pump in the same location of the stock pump. I am not sure why there is gas in the pulse line, I started to think about it and maybe its because I had my thumb over it and caused it to suck gas/oil mix from the crankcase. It didn't idle very good after I did the repairs but i thought it was because of it being cold natured sometimes.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Can you post a clear photo showing where the pulse line and fuel feed line is connected to your fuel pump?

  7. #7
    yes, I can try tonight to get a picture of it. I am still curious if my thumb over the pulse line caused suction and that is what caused gas to come out becuase it did not do it at first without my thumb over it.

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    The pulse hose shouldn't pull any gas, unless there's fuel in the crankcase, or the fuel pump diaphragm is punctured.

  9. #9
    when I got home tonight I removed the pulse line and there was just air coming out no gas, I removed the feed line to the pump and its getting gas to it just not to the carbs??? I wasn't able to get my camera to download a pic for some reason.

  10. #10
    ok, I think I figured it out.. I did a little more diag this morning before work and found that the coke bottle I used to catch the gas in last night was about roughly 1/3 water.. I bought this ski months ago and only used it once for about an hour before it leaned out the front cylinder, it still had the same gas in it from when I bought it. I am going to pump the tank tonight and hopefully all will be good.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New fuel pump placement?
    By tenjuna in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-31-2011, 08:50 PM
  2. Need a new fuel pump
    By KanBama in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-04-2009, 09:31 AM
  3. New Fuel Pump
    By cdieter in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 05-05-2009, 05:05 PM
  4. running lines for new fuel pump
    By sullified in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-15-2008, 03:52 PM
  5. 94 750 SL fuel pump?
    By rfjr23 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-03-2007, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •