Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    May 2008
    Location
    Charlottesville VA
    Posts
    39

    Been chasing this GPR problem for a while now... Please help

    I have a 2001 Gp12R with 120 Hours. The ski has a protec head, ride plate, intake grate, turbo tube, F/A's, Waveeater clips and couplers, converted to premix and some other minor bolt-ons.

    Here is my question, the ski ran great all last summer but, on the last weekend on the water before i winterized it, I noticed that it had a bog when making hard turns and while accelerating/trying to get on plane. So, over the winter, i did compression check(130-131-129) and a complete rebuild on the carbs and found that the jetting was way off from the previous owner. So, i rejetted to the following specs in hopes of removing the intermintent "bog".

    pilot 110

    main 125
    Needle and seat 1.5
    spring 95 gram
    accel. Pump disabled
    1 turn lows
    1.5 turns highs

    Then, i had the ski out 2 weeks ago with no problems, ran much better and i put about a 1/2 hour on the water. But, I had it out yesterday and the bog came back. I rode for about and hour and noticed it really started bogging after 15 mins of 18-20 mph crusing. It now idles perfectly, starts right up, and begins to take off when you add throttle but, it then bogs and will not pass 8-9 mph. I tried replacing the plugs, adding dry gas, checked the pump for debris, checked all lines and everything seems normal. I have not checked compression this season yet but, last year it was fine (need to get a new guage/old one broke).

    Any ideas?? I really feel like its something in the fuel system/carbs that needs attention. Please advise me on where to start.

    -Darren


  2. #2
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11

  3. #3
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,156
    +1
    44
    I would also wonder about popoff pressure. Did you check it when you rebuilt the carbs?

  4. #4
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    I agree. That stupid flapper Nailed me a few times

  5. #5
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,363
    +1
    55
    i had this same problem with my ski, it almost drove me crazy try'n to figure it out,
    and it was the fuel selector nob aparently it was sucking air and when coming out of a turn or under load it would bog,,
    before i eliminated the fuel selector nob i removed the fuel flapper in the tank but didnt solve it, so the selector noob was my issue

    good luck man.

  6. #6

    Join Date
    May 2008
    Location
    Charlottesville VA
    Posts
    39
    Hey guys, i will try the fuel flapper valve this weekend. Also, moving the selector knob does nothing. Weather its on reserve or "on", it still bogs.

  7. #7
    gaz1's Avatar
    Join Date
    Jan 2008
    Location
    Uk
    Posts
    162
    Do you have the choke plates in or out?i have just done the excact same jetting specs with my carbs,i thought it would've been 120 mains with the chokes in,125 without.Also i take it you have replaced your fuel filter since doing your carbs?

  8. #8

    Join Date
    May 2008
    Location
    Charlottesville VA
    Posts
    39
    Fuel filter replaced and choke plates still installed.

  9. #9

    frozen fuel selector valve

    hey guys: 1999 xl1200

    had the same problem , after 2 months of chasing the problem and a lot of money . it was a frozen fuel selector valve stuck half open half closed so when i gave it throttle it would BOG. replaced the valve , problem solved. all of he following was not necessay :: complete rebuild on the carbs , removed the fuel flapper , compression check , Waveeater clips and couplers, converted to premix , D plate .... but now the ski is damm fast.

    hope this helps.

  10. #10
    philip_gpr's Avatar
    Join Date
    Dec 2005
    Location
    Canada
    Posts
    2,724
    +1
    3
    just an idea,

    on my skis I disconnect the fuel selector valve - I run a line directly from the reserve feed on the fuel sender to the fuel filter and then to the carbs

    if you decide to leave the fuel selector knob in place then I would always use the reserve setting

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looking for wiring diagram for a 99 slh, please help!
    By rharvey85 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-23-2011, 03:00 PM
  2. Replies: 3
    Last Post: 09-08-2010, 09:07 AM
  3. electrical cdi box wiring for 1996 780 slx, please help
    By Polar in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-28-2010, 10:03 PM
  4. Wired noise while airborne Please help
    By sebas54 in forum Polaris How To & FAQs
    Replies: 23
    Last Post: 05-10-2010, 03:14 PM
  5. Trim problem on my XP 800.Please help before i smash it
    By TMPLUMBER59 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-16-2009, 10:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •