Results 1 to 6 of 6
  1. #1

    Need Help With 08 15F SLO Mode...

    We went riding this weekend in the Gulf. It started to smooth out in the afternoon and we had some rollers coming in through the pass around 4 - 7 feet.

    Obviously, we went and had some fun...

    My brother in law was riding my 15F and hit a wave and when he landed, it went into SLO mode. It says SLO on the gauge.

    How do I get it out, and why would it do this? Did we rattle a sensor somewhere maybe?

    I've tried holding the mode button while turning the orange key on and it remains in SLO.

    Any help would be Great!!!

    Why are all moto shops closed on Mondays?...

    Thank you.


  2. #2
    Just turn the orange key to ON an while the ski is off hold any button down for 7 seconds and it should turn SLO off. Why it went into that mode is another question.

    I know my boat engine would do it when it was trying to minimize damage.

  3. #3
    Team N2L #112 *Monster 15FKawi*'s Avatar
    Join Date
    Jun 2008
    Location
    Cayman Islands
    Posts
    154
    Oh. I've had this happen to my 08 15F too.. after i came from riding Off-shore. a good bit of salt water some how got into my console,and corroded the board..

    I had to replace the whole console.. i would try unpluging the console wires 1st and spraying some cleaner into them.. & let it dry.

    hope you get it sorted out bro.

  4. #4
    Quote Originally Posted by ThePerchik View Post
    Just turn the orange key to ON an while the ski is off hold any button down for 7 seconds and it should turn SLO off. Why it went into that mode is another question.

    I know my boat engine would do it when it was trying to minimize damage.
    That worked today. I thought I tried that when it happened... Maybe something had to dry off.

    I'll keep an eye out on it though.

    Thanks for the help!

  5. #5

    A Safety Feature

    In the operators manual it talks about safety features that will limit speed to save damage to the ski. If it has corrected itself then I imagine something did get wet or overheated. You might want contact a service center and find out how it will cost to pull the engine codes to ensure you do not have any permanent damage.

  6. #6
    You might want to check out the recalls on this jet ski. The Ultra 250X had a recall where water was splashing in just in front of the handlbars. If you open your hood and there is not a plate cover the hole below the pin then that is the problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. stx 15f need help with jet pump removal (new to forum and need your help)
    By Geno in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 02-24-2012, 09:53 PM
  2. Needs help with kawasaki stx 15f power filter
    By centrino in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 07-14-2011, 04:43 AM
  3. Need help with modding my 08 RXP 215
    By AthleticKid818 in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-12-2009, 07:53 PM
  4. Need help with pump issue
    By Flyer in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-23-2006, 05:40 PM
  5. Need help with 04 S.C. rebuild
    By Turbo Todd in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-10-2006, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •