Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: NEED HELP

  1. #1
    EROD Palm Beach Punisher's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    380
    +1
    3

    NEED HELP

    I have a gprxpx and iam having trouble when i give it full throttle it spit and spudders then it takes off.i replaced the plugs but it's still doing the same thing.does anybody have any info


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Toss this question in the 4TEC section, since its a Rotax motor...

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    could be rich on the bottom end or a cylinder about to crap out (lose compression) for one of many possible reasons..

  4. #4
    Autosport's Avatar
    Join Date
    Feb 2007
    Location
    In the Fast lane
    Posts
    1,587
    +1
    25
    could be a leaking intercooler, with water getting in the intake...
    could be fuel related
    could be blocked exhaust issue
    could be a number of things... need to start with the basics and start working forward.

  5. #5
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Did it ever run correctly?

  6. #6
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    176
    it was a low hour x motor if i remember correctly.

  7. #7
    EROD Palm Beach Punisher's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    380
    +1
    3

    help

    it has 44hrs on it at first i tought it was my ign switch because the lid keeped lifting up were i mounted it.but i fixed the lid and it keeps doing the same thing.it never did it until i did the conversion

  8. #8
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    176
    erik, is everything grounded properly?

  9. #9
    EROD Palm Beach Punisher's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    380
    +1
    3

    help

    i checked it and i had a friend who put all the ground wires together i put them on the way it should and i'll let you know if that fixed it

  10. #10
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62
    [quote=erik rodriguez;1041585]i checked it and i had a friend who put all the ground wires together i put them on the way it should and i'll let you know if that fixed it[/quote Time to pay me

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new 05 RXT NEED HELP
    By RXPNJ in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-03-2009, 12:16 PM
  2. NEED HELP URGENT(HULK) RXP DOWN
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM
  3. My 2 RXP's need HELP!
    By Tube Master in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-19-2005, 09:44 PM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •