Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    GROOVY MAFIOSO's Avatar
    Join Date
    Apr 2008
    Location
    TAMPA,FL
    Posts
    85

    Will no oil filter cause a poor oil pressure?

    I just checked my oil filter after getting my ski back from an engine rebuild, and I was having poor oil presure. Oil light/alarm was going off...
    Seadoo dealer never put a filter in!! I'd say I ran it for about 5 hours, mostly idle.. very rarely if at all w.o.t.

    concernd




    2004 Seadoo RXP s/c


  2. #2
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    I don't know? Put a filter in and see what happens. Wonder what else the dealer forgot to put back in the engine?

  3. #3
    If that happened to me id make him tear the motor down again!! The last thing u want is all the metal filings from the new motor breaking it self in going through your engine.

  4. #4
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    i agree thats bad after a rebuild.
    either make the dealer redo it, or give you a free rebuild next time you need one, no questions asked.
    either they pay for it now, of maybe if it never needs it they avoid paying for it later, but if it does need it, they should pay for it. 1 free rebuild for as long as you own the ski would be fair.

  5. #5
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    no but the debris from the engine will score up and make the releif valve sticky causing low pressure.
    and as above its really not good as any filings will have damaged the bearings instead of getting trapped in the filter

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    If the engine was rebuilt due to a SC failure, chances are that they reused the oil pumps. Did you get an itemized list of the parts changed for the rebuild?... Ron

  7. #7
    GROOVY MAFIOSO's Avatar
    Join Date
    Apr 2008
    Location
    TAMPA,FL
    Posts
    85
    no s/c failure. was do to salt water ingestion. and the dealer did not get all the water out and while waiting for parts, the rings went bad... its a long story they wont do crap for me. i screamed so much.
    but even barely using the ski changing the oil wouldn't help now?

  8. #8
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    You might want to post the particular dealer so that others can avoid your pain. Don't forget, what you spent to repair the ski can be deducted as a casuality loss on your income tax for 2009. It takes alot to reach the 10% base, so every thing helps... Ron

  9. #9
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    Quote Originally Posted by GROOVY MAFIOSO View Post
    but even barely using the ski changing the oil wouldn't help now?
    change the oil and put in a filter to attempt to minimize the damage. there are several people on here that sound like good techs that are in your area, find one and let them check out everything for you.

  10. #10

    Join Date
    Apr 2008
    Location
    Blaine,MN
    Posts
    72
    take that back and MAKE them put that filter in. call the BBB and the county general about that dealership. when they get the BBB notice i know u wont be screaming anymore. hand write a letter to both of them why u arent satisfied about that company and the general will send u a letter back on wether or not he/she will help u.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 Honda aquatrax no oil pressure
    By kdevarney in forum Honda Open Discussion
    Replies: 6
    Last Post: 09-20-2016, 01:02 AM
  2. Low or no oil pressure.
    By jh6398 in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-28-2016, 05:28 PM
  3. 04 215 4tec, no oil pressure at idle
    By toxicgun in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-07-2016, 11:24 AM
  4. Replies: 18
    Last Post: 10-19-2011, 04:35 PM
  5. No Oil Filter in the Online Store
    By cbrich in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 03-24-2008, 10:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •