Results 1 to 5 of 5
  1. #1
    MDGPR's Avatar
    Join Date
    Apr 2006
    Location
    MD
    Posts
    238
    +1
    1

    fixing my low rpm's

    Ok, so about a month ago i posted some things about my ski only tunring 6750 rpms. my prop was very dinged up so i sent it to island racing. havent got it back yet when i get it back, after reading and gaining knowledgeon all the post i think i can go find those lost rpms.i think if i fix these symptoms

    - I think i will gain alot back when i put the fixed impeller on

    -my plugs might have failed due to a poorly tuned efi

    -efi is tuned wrong

    when i first installed my free flow, i had it all screwed up, their wer eno leaks but i used a stock tubing and it curved upward to the top of the rear void, then the free flow(the r&d that is just a metal tube with no bend) went streight down to the 90 hull fitting. after i saw some pics of what it should like i have it 45 ing out of the water box then runs level across the hullthen 90's to the hull fitting. It was a catastrophe but no it is nice and clean. with fixing that will i have gained some rpms back? there were never any leaks.

    i want to go test it but i have to wait on my impeller


  2. #2
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Sounds like you are starting to understand the importance of details!

    Keep us informed on your progress!

  3. #3
    flyboy's Avatar
    Join Date
    Nov 2005
    Location
    Destin, FL
    Posts
    1,585

    Re: fixing my low rpm's

    Quote Originally Posted by MDGPR
    when i first installed my free flow, i had it all screwed up, their wer eno leaks but i used a stock tubing and it curved upward to the top of the rear void, then the free flow(the r&d that is just a metal tube with no bend) went streight down to the 90 hull fitting. after i saw some pics of what it should like i have it 45 ing out of the water box then runs level across the hullthen 90's to the hull fitting. It was a catastrophe but no it is nice and clean. with fixing that will i have gained some rpms back? there were never any leaks.
    as long as it didn't leak, and there were no crimps, I don't think you will gain any RPMs from rearanging the placement of the R&D tube

  4. #4
    MDGPR's Avatar
    Join Date
    Apr 2006
    Location
    MD
    Posts
    238
    +1
    1
    it may have had some crimps in it, but not kinks. i cant get started until i get my impellar. could i be losing all these rpms through those couple things? thanks for all your help in advanced.

  5. #5
    MDGPR's Avatar
    Join Date
    Apr 2006
    Location
    MD
    Posts
    238
    +1
    1
    so just looking through my jetksi tring to find some more causes, my jetworks valve is the regular one where you insert the washers, when i take it apart there is only a spring and a washer in it, should there be something more? would this cause a loss?

    im going to post some pictures of the color of my plugs, im not sure what color they should be, im red/green color blind. so its kidna hard to tell what color it should be.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Low RPM's on my Cane'
    By bigpak in forum Polaris PWC Performance
    Replies: 0
    Last Post: 08-14-2014, 05:51 AM
  2. Found out what was chasing my low rpm and low mph
    By travis ingram in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-14-2014, 08:50 PM
  3. Cheap low RPM vibration fix for 300x
    By Jaxtripp in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 06-30-2012, 09:10 AM
  4. Kind of low rpms, is it my impeller?
    By super_gtx in forum 4-Tec Performance
    Replies: 15
    Last Post: 07-10-2008, 03:27 PM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •