Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1

    2001 Xp tuning help please

    I have a brand new 951 motor with about a tank of fuel through it, it has aftermarket flame arrestors on it and a jet ski, all came from Watercraft Magic. The main is 167.5, pilot is 85, 2.3 needle and seat, high speed is open 1/8, and low speed is open 1.5 out. All are specs from the install sheet. The problem is, from an idle, if I punch it, it will rev to about 6500 then fall flat on its face and stall out, sometimes I can catch it if I burp the throttle other times it just dies. It also does it from an idle if I go to half or quarter throttle. Once it pulls it does pull very hard at about 6900ish rpm which it what Bill Oneil says it should. I have tried both opening and closing the low speed needle very little and nothing seems to clear it up. The fuel pump accelerator is working too. I have no idea what this could be. Any info is greatly appreciated.


  2. #2
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    The lows are for adjusting at idle. Anything above that and you need to focus on the highs. It almost sounds like it's seizing. You need to do a plug chop and maybe a compression test if it is seizing. Hopfully your just flooding it and just need to close your highs. A plug chop will tell the story.

  3. #3
    I am still waiting to finish breaking in the motor to do a plug chop. I tried the highs closed and it was so small of a difference if any. The only thing that might have affected it was air temp from one day to the next. The motor is a brand new rebuild so I would assume compression is fine. What do you mean by seizing? When it does die out if I burp the throttle I can sometimes catch it and keep it running. I did check the plugs and the insulator nose is a light brown/tanish color, and the ground strap is the same with a small black spot near the end by the threads. Again this was not a plug chop just checking them to see how they look.

  4. #4
    abarrassr07's Avatar
    Join Date
    Aug 2008
    Location
    Louisiana
    Posts
    424
    Quote Originally Posted by jwick86 View Post
    I have a brand new 951 motor with about a tank of fuel through it, it has aftermarket flame arrestors on it and a jet ski, all came from Watercraft Magic. The main is 167.5, pilot is 85, 2.3 needle and seat, high speed is open 1/8, and low speed is open 1.5 out. All are specs from the install sheet. The problem is, from an idle, if I punch it, it will rev to about 6500 then fall flat on its face and stall out, sometimes I can catch it if I burp the throttle other times it just dies. It also does it from an idle if I go to half or quarter throttle. Once it pulls it does pull very hard at about 6900ish rpm which it what Bill Oneil says it should. I have tried both opening and closing the low speed needle very little and nothing seems to clear it up. The fuel pump accelerator is working too. I have no idea what this could be. Any info is greatly appreciated.
    i ran my hs closed with your set up and found i was still rich. did you clean the carbs lately, the filters? check fuel filter

  5. #5
    Yes I forgot to mention I did go completely through the carbs and clean the internal filters and the big outter filter and have replaced all the fuel lines too. What did you change to on your jet if this set up is still rich?

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    What kind of flame arrestors are you running?

  7. #7
    R&D flame arrestors. They are just the filters that clamp directly to the stock airbox adapter. It was sold to me as a complete kit filters and re jet kit all in one.

  8. #8

    Join Date
    Apr 2005
    Location
    Eureka, MO
    Posts
    404
    +1
    1
    did you also clean your selector switch?-- often over looked.

  9. #9
    Yes I cleaned the selector switch. I read the post here and did what was done here. I forgot to mention that too.

  10. #10
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Even with R&D, I find it hard to believe you are rich. You mentioned brand-new engine, did you get the timing verified? Most of the time when a rebuild is placed in an original programmed MPEM, the new engine is retarded more than the old engine. 1-2 degrees kills the performance of an engine.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tuning help please. 1997 XP with aftermarket crap
    By Pbacon56 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-30-2016, 10:44 AM
  2. 2001 Polaris Virage Help Please :-)
    By YoCoLifSavr in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 05-30-2010, 11:36 AM
  3. dead xp limited help please
    By clownhands in forum 2-Stroke Performance
    Replies: 20
    Last Post: 10-27-2009, 07:56 PM
  4. 2001 polaris virage help please
    By h23pasadena23 in forum Polaris Open Discussion
    Replies: 22
    Last Post: 03-19-2008, 10:32 AM
  5. A little more XP800 tuning help please...
    By javiert99 in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-08-2006, 12:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •