Results 1 to 3 of 3
  1. #1

    XL1200 Ltd - Help with pics

    Hi guys! Spring is finally starting to break here in northern Indiana. On my 2000 XL1200Ltd I am putting a Solas impeller on. My questions are:

    1) Should I replace my stock aluminum pump tunnel liner with the plastic? If so can I just pop out the aluminum and put in the plastic pump tunnel liner??? I do not have bad corrosion around it but it looks like some cavitation burn. See Pics.

    The ski cavitates bad. I have the PPK, but I have removed the pump shoe and I am going to try to seal it up better.

    I also am swapping the exit nozzle for the 5 degree.

    Any thoughts on pump tunner liner?
    Thanks! Cant wait to get out and ride!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	jet ski prop1.jpg 
Views:	63 
Size:	10.5 KB 
ID:	129001   Click image for larger version. 

Name:	jet ski prop 3.jpg 
Views:	62 
Size:	11.1 KB 
ID:	129002   Click image for larger version. 

Name:	jet ski prop clearance.jpg 
Views:	59 
Size:	7.2 KB 
ID:	129003   Click image for larger version. 

Name:	jetski prop tunnel.jpg 
Views:	65 
Size:	12.0 KB 
ID:	129004  

  2. #2
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    United States
    The oem wear rings have a stainless liner. The early model ones were thin and swelled from corrosion. If it needs replacing you need buy a new one or one that has been modified with the plastic wear ring.

  3. #3
    can you tell from the pictures if mine looks like it needs replacing? It has some cavitation burn (I think that is what it is called), but no corrosion pushing the edges up or anything....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 xl1200 ltd HELP!
    By Jbak3r615 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 09-17-2013, 07:55 PM
  2. 99 xl1200 ltd HELP! no spark
    By Jbak3r615 in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 08-07-2013, 06:51 PM
  3. XL1200 LTD died with no spark
    By babywolfxll1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 07-30-2011, 08:37 PM
  4. sea doo gtx ltd help with mods
    By omarleon999 in forum 4-Tec Performance
    Replies: 3
    Last Post: 01-28-2011, 09:11 PM
  5. Seadoo Gti Le 2004 Help With Pics
    By gtile04 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 11-12-2009, 09:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts