Results 1 to 5 of 5
  1. #1

    '97 1050 SLTX Engine install

    Spring project to rebuild my 1050 is almost complete but I need some advice on the reinstall. What do I need to do to ensure proper engine/driveshaft alignment? The pump and driveshaft have not been removed but I did have to replace the motor mounts. I have shims for the mounts but again how do I ensure the proper alignment when the motor goes back in?


  2. #2
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    The instructions are here... http://www.greenhulk.net/forums/atta...2&d=1168728476


    It would have been easier to pull the engine by pulling the pump first I think. It would also be easier to install the engine with the pump pulled.

    You really need an alignment tool. Beerdart rents them.

  3. #3
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Here's beerdarts instructions.
    Attached Files Attached Files

  4. #4
    Thanks for the quick response, starflight. Just curious, why the need for a tool if it is just slid into the coupler similar to the driveshaft? Wouldn't just sliding the driveshaft through give you the same indication of misalignment?

  5. #5
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    The tool is long enough to push it through the stator to "feel" perfect alignment. If it slides in with only slight resistance, it's good. If alignment is slightly off it won't slide in easily. Trying to install the whole pump assy, you won't be able to "feel" if its binding going in. Even with things perfectly aligned, you get alot of resistance at times installing the pump assy.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Got a 97 1050 sltx....woooohoooooo
    By Lxtasy in forum Polaris Open Discussion
    Replies: 13
    Last Post: 08-18-2016, 05:34 PM
  2. 97 polaris sltx 1050 won't start!
    By sltx1050 in forum Polaris Open Discussion
    Replies: 67
    Last Post: 08-27-2015, 11:34 PM
  3. 97 sltx 1050 rebuilt engine
    By hill313 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-21-2014, 07:45 PM
  4. '97 SL 1050, Ignition Update Install Questions
    By thynes in forum Polaris Open Discussion
    Replies: 13
    Last Post: 08-30-2011, 12:52 PM
  5. 1050 SLTX Engine Troubles
    By Pwgsx in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 08-03-2011, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •