Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1

    Clutch Failure round 2

    My clutch went out again today. I think I may be backing down to the C1 wheel. I was running the R&D BOV. I had about 4 hours on the new clutch when it went out.

    Who is running the c3 without any issues? I wonder what is going wrong with my ski?


  2. #2
    Banned User
    Join Date
    Jun 2008
    Location
    kingwood,texas
    Posts
    526
    +1
    1

    wow

    man sorry to hear that. do u think it might be something else?

  3. #3
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by allstar71 View Post
    My clutch went out again today. I think I may be backing down to the C1 wheel. I was running the R&D BOV. I had about 4 hours on the new clutch when it went out.

    Who is running the c3 without any issues? I wonder what is going wrong with my ski?
    Dam.. Occur with or without your BOV in place??

    Edit.. Just reread. Saw you had the BOV in.

  4. #4
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    WTF!?
    I think you have been cursed?

  5. #5
    Banned User
    Join Date
    Jun 2008
    Location
    kingwood,texas
    Posts
    526
    +1
    1

    speed?

    how fast were u going with the c3?

  6. #6
    Banned User
    Join Date
    Jun 2008
    Location
    kingwood,texas
    Posts
    526
    +1
    1

    rev limit?

    are u bouncing off the rev limiter alot? do u go from full throttle to zero alot? or are u easying off slowly?

  7. #7
    performance enthusiast AD4342's Avatar
    Join Date
    May 2006
    Location
    Abu Dhabi, UAE
    Posts
    296
    +1
    1
    what engine oil are you using??

  8. #8
    I dont think I am on the rev limit? but I may be. no I have been easing it off. it was ruff today and it hits the limiter hard when it looses hookup...but when it happeded I was doing a speed run...
    Last edited by allstar71; 05-05-2009 at 05:19 PM.

  9. #9
    Quote Originally Posted by BadGP1300 View Post
    what engine oil are you using??
    not sure what engine oil whatever the dealer put in?/

  10. #10
    Quote Originally Posted by onebadsho View Post
    man sorry to hear that. do u think it might be something else?
    I havent pulled the intake off but its doing the same exact thing and all of the hoses are still in place. dont know what else it could be.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Supercharger Clutch Failure
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 52
    Last Post: 02-06-2006, 07:38 AM
  2. Is this a clutch failure?
    By kenshin89 in forum 4-Tec Performance
    Replies: 11
    Last Post: 09-15-2005, 09:39 PM
  3. S/C Clutch Failure.
    By Big Red Monster in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-30-2005, 08:22 PM
  4. SC Clutch Failure Sreen?
    By RXDI2 in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-16-2005, 12:14 PM
  5. Pics of S.C. Gear after clutch failure
    By two2curupt in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-10-2005, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •