Results 1 to 8 of 8
  1. #1

    65u Riva CDI revB

    I have a RIVA CDI for 99 GP1200 or in this case a triple piped WB2-1200. Cylinder #3 has no spark and I have isolated it to the box and not the coil. Is there a fix or am I shopping for another CDI? Box is revision B. Thanks for the help...


  2. #2
    ....back from the dead.... J-ME's Avatar
    Join Date
    Aug 2005
    Location
    Delaware
    Posts
    1,577
    +1
    2
    I don't know of anyone that actually repairs CDIs. Check with Randy of Watcon to see if he knows anyone.
    If you can get through all of that potting it is probably an easy fix for someone who specializes in automobile ECMs and PCMs.

  3. #3
    ....back from the dead.... J-ME's Avatar
    Join Date
    Aug 2005
    Location
    Delaware
    Posts
    1,577
    +1
    2
    If you find another one let me know as I would like to buy your broken CDI to tinker with.

  4. #4
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    I have to ask but did you get ohm readings from the three pulser coils?

  5. #5
    Osidebill, I changed the coils around and the coils along with plugs and wires are all working. Its just that cyl #3 has no spark, if I simply plug wire #2 or #1 into the #3 coil it works. Doing a quick web search it seems that there are alot of these CDI's that don't work out there. Hopefully someone has gotten one fixed...
    If I am SOL, anyone have some advise on getting that potting cover off? I probably know a guy that could fix it, but getting into it is another story.
    Thanks

  6. #6
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    I have heard the same things about the riva CDI I had my stock one modded by Pro-Tec but I believe this is non invasive he sends them out to someone to get them done you may want to give him a call.

  7. #7
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    I may have mis-understood your post I was speaking originaly of the pulser coils (pick-ups) they are located in the front cover there is a plug that goes in to your cdi 4 wire w/rd, w/gr, w/blkand blk you can check resistance on these between the black and then each of the three wires these tell your cdi when to fire resistance should read between 248-372
    have you checked these?

  8. #8
    Stock CDI and everything works. I didn't try the resistance test.
    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 65u 1200 Riva CDI
    By Mpeavler in forum Yamaha Classifieds
    Replies: 31
    Last Post: 01-19-2009, 09:40 PM
  2. Wtb Riva Cdi 65u
    By big raider in forum Yamaha Classifieds
    Replies: 5
    Last Post: 10-02-2008, 01:55 PM
  3. Riva Cdi 65u
    By big raider in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 09-14-2008, 10:46 PM
  4. WTB RIVA CDI 65u
    By big raider in forum Yamaha 2 Stroke Skis
    Replies: 0
    Last Post: 09-14-2008, 07:49 PM
  5. 65U Riva CDI help
    By HCP Designs in forum Yamaha Old School Skis
    Replies: 20
    Last Post: 09-20-2007, 09:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •