Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Jun 2006
    Location
    Peoria, AZ
    Posts
    65
    +1
    2

    Popoff help needed!

    Hello guys, just discovered the forum today while trolling for GPR links. Glad to find another active forum.

    I posted this on the RIVA forum but didn't have much success so maybe someone here can help.

    I am in the process of rebuilding my carbs. I have jetworks mod, 145 psi head, stock airbox with screen on and snorkel removed, pro-tec reed stuffers, free-flow exhaust, and stock stinger.

    I rebuilt my carbs with 110 lows, 120 highs, 1.5n/s, and I'm not sure what springs but I believe 95g. They appear to be grey in color. They are definitely not black or gold like the stock springs. I am getting popoffs between 48 and 53 psi.

    What should I be going for with this setup?

    Also, anyone on here from the Phoenix area?


  2. #2
    Welcome to the forum! Someone should chime in with what you need, more good info here than at Riva

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Welcome to the forum

  4. #4

    Join Date
    Jun 2006
    Location
    Peoria, AZ
    Posts
    65
    +1
    2
    Cool, thanks for the welcome. Can't wait to start participating.

  5. #5

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    wow,high temp low humid.well if here in sunny fla.something like 1 1/2 high (keep that #3 cylinder FAT) and 1 turn low to start/do you know what prop AND have you bypas that fuel valve yet and done twin pickups (I'm a real freak on doing that mod)have fair tach.?

    later cd

  6. #6
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    Chip you part of TeamTweek?
    I run an advent on my setup, which gives me a little room to play with on the 3rd cylinder. I run the same jet specs you do, except I run an 80 gram spring. Gets me to about 40 psi. I changed my springs and my jet in the rear that my buddy Dave had put in just to see if it would clear out my low end bog and it did just that. He had me setup pretty close to where I needed to be at. I run the highs out at 1 1/8 on the first two front cylinders and 1 1/4 on the rear. I run the lows at 1 turn out. This is with the riva flame arrestors.
    SHOOTER

  7. #7

  8. #8
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Phoenix? Never heard of it.

    WELCOME!

  9. #9

    Join Date
    Jun 2006
    Location
    Peoria, AZ
    Posts
    65
    +1
    2
    Quote Originally Posted by hydrotoys
    Phoenix? Never heard of it.

    WELCOME!
    Thanks, thanks. I'd imagine you probably ride the east valley lakes?

    On your lake boat, what setup are you running intake/exhaust wise? I'm thinking about just swallowing my damn stock intake pride and going with the F/As. It's hard to get a popoff answer on my setup since everyone is running F/As.

  10. #10
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Oh we ride whereever, including lake unpleasant. Thinking about a bartlett trip this Friday. Interested?

    Stock ain't that bad. Why not set it up stock, and check out the popoff, and deviate from there until it runs the way you want it? Quite frankly, if it doesn't run up to around 7000rpms stock then something is wrong anyway, and I doubt it's the jetting.

    The jetting mentioned here is WAY to big for Phoenix, AND stock flame arrestors together.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Home Audio Help Needed
    By Franko in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 08-24-2007, 10:45 AM
  2. Help needed on ZXI 1100
    By Turbo Todd in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-18-2005, 11:49 AM
  3. Help needed
    By rxpblast in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-07-2005, 09:20 AM
  4. Help needed badly!
    By RXPinMD in forum 4-Tec Performance
    Replies: 37
    Last Post: 07-06-2005, 10:03 PM
  5. Help - need RXP battery dimensions
    By Vern in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-28-2005, 05:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •