Results 1 to 8 of 8
  1. #1

    99 xlt1200 cavitation problems

    Hello, I'm new to the forums and I am hoping you guys can help me out. I have a 99 yamaha 1200 with what I believe is cavitation issues. The ski has 48hrs on it and the issue only seems to noticeably arise when I am pulling someone. I have to adjust the trim as low as it can go and when I pull a tube in a turn for example if feels like it just spins...the motor revs up but there is no go i have to let off the throttle and then get back into it. I couldn't see any damage to the impeller....and the top speed with me on it is still there as I can beat my dads 08 gti on top end. But I use the ski mostly for pulling and out of the hole....and ideas what it could be?

    Also it has a new motor in it as a oil line came off and blew the motor. The motor has 6 hours on it and now runs with a block off plate. And at low end all i can hear pulling away is it popping(missing) keep switching plugs and go a bit light on the oil ratio and get nothing any ideas on that as well????

    Thanks


  2. #2
    For the cavitation, have you installed the pump plug kit and installed a R&D/Riva intake grate? I had the same problem with my 2001 XLT1200, but it all went away with these 2 simple upgrades.

  3. #3
    It is completely stock only thing on it is a block off plate. Any idea about the missing? And where do I get those kits at?

    So good news would be you dont think its the impeller?

  4. #4
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    Have the carbs been rebuilt and rejetted? ppk and tube of 3m5200 fast cure caulk(10oz) should take care of the cavitation

  5. #5
    Yes, The carbs were redone I believe when the motor was done. It never missed before until we redid the motor with the block off plate and went to premix. I have been mixing it at 36:1. Where do I get the kit at? Is there detailed instructions on how install it? Should it be necessary with such low hours?

  6. #6
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    Quote Originally Posted by Kcauley View Post
    Yes, The carbs were redone I believe when the motor was done. It never missed before until we redid the motor with the block off plate and went to premix. I have been mixing it at 36:1. Where do I get the kit at? Is there detailed instructions on how install it? Should it be necessary with such low hours?
    Yes it is the design of the pump.... it needs it, the caulk you can get from west marine for 20 bucks...

    here is the addy for the pump plug kit, its the online store that operates this forum
    http://www.4-tecperformance.com/inde...oducts_id=1065

    here is a link to riva install instructions
    http://www.rivamotorsports.com/instructions/ry2519.pdf

    and def get the new intake grate, it will throw you off at 60 mph if you dont....

    Need something else, keep asking... someone will respond to the carb question...

  7. #7
    Thank you for the quick response...now to save up some money and get those mods. I am going to get the pump kit and a intake grate and also a ride plate.....It has a d-plate it it as well....any other mods that need to be done??

  8. #8
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    if it was me.... 99 bucks for waveater clips.... then 100 bucks for grate and 85 for a ppk plus 20 bucks for the 10oz tube of caulk.... then save for a modified rideplate... between 450 and 500....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Newbie w/ 1994 SP, cavitation problem
    By Stumpotto in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-28-2007, 05:14 PM
  2. 99 gp760 starter problems help!!
    By 07vette in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 06-18-2007, 10:59 PM
  3. Cavitation problem solved!!!!!
    By Rendog in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-21-2007, 08:22 PM
  4. 99 Xlt Cavitation Problem
    By hammerdog57 in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 01-25-2007, 01:36 PM
  5. Cavitation Problem? Help!
    By NeverEndn in forum 4-Tec Performance
    Replies: 41
    Last Post: 08-10-2006, 10:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •