Results 1 to 7 of 7
  1. #1
    abarrassr07's Avatar
    Join Date
    Aug 2008
    Location
    Louisiana
    Posts
    424

    fuel pump will not kick on when key is in

    rxp still won't start, new ecu, new mpem, and supposedly new fuel pump was changed two weeks ago. i can't hear the fuel pump kick on when i put the key in, the code went away sense i put the new mpem on but it still beeps four times every few seconds. they had a 30 amp fuse where the 10 amp fuse goes for the fuel pump, is it possible they fried this fuel pump?? how do you test it to see if its functional or if it is not grounded


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    fyi the beep every few seconds is completely normal.

    Here is a link to the shop manual
    http://www.mediafire.com/?t4xocc4myts

  3. #3
    abarrassr07's Avatar
    Join Date
    Aug 2008
    Location
    Louisiana
    Posts
    424
    thanks. didnt know that, im a noob with 4 strokes.

  4. #4
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    If someone replaced the fuel pump... theres a chance they ended up with a china knock off of a walbro pump Others have stated they last about 3 hours

  5. #5
    abarrassr07's Avatar
    Join Date
    Aug 2008
    Location
    Louisiana
    Posts
    424
    Quote Originally Posted by bigdaddyRXP View Post
    If someone replaced the fuel pump... theres a chance they ended up with a china knock off of a walbro pump Others have stated they last about 3 hours

    its a bosch. well i found the problem!!!! bypassed the ground to the battery and the pump ran continuously then ski started right up until it burned out the gas that was pumped in by the pump. so i got a new harness on the way... thanks for the help...

  6. #6
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Sweet

  7. #7
    abarrassr07's Avatar
    Join Date
    Aug 2008
    Location
    Louisiana
    Posts
    424
    id say man. my head lit up like a Christmas tree when i heard that pump come on. ive invested $400 to get an rxp running. i have a $2400 rxp with 150 hours. i will post pics of it later. i was a happy camper when i got it to start.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help rxp stays on when key is not in please help
    By vicario62590 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-05-2014, 06:37 AM
  2. 01 XPL fuel pump will not turn on...
    By My09RXPX in forum 2-Stroke Performance
    Replies: 13
    Last Post: 06-10-2014, 11:18 PM
  3. 1999 Genesis, no start, fuel pump does not run when cranking
    By RIDEH2O in forum Polaris Open Discussion
    Replies: 22
    Last Post: 08-20-2013, 05:10 PM
  4. Pro cdi and 780 will not work on 94 650..
    By Rodneyae in forum Polaris Open Discussion
    Replies: 25
    Last Post: 05-16-2007, 07:48 PM
  5. PUMP SHOE NOT ALIGNED ON GPRS WITH THE 2'' EXTENTION
    By ABBOTT in forum Yamaha How To & FAQs
    Replies: 15
    Last Post: 01-20-2006, 02:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •