Results 1 to 8 of 8
  1. #1

    Is alignment needed after pump removal?

    Pulled pump for a New impeller on 97' 785. Is it necessary to align anything? Seems to me like the pump will only go back in one spot, but just checking.

    Thanks, Ryan


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    You just pulled the 4 long bolts not the ones that go through the hull correct .
    if you just pulled the long ones you are fine

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Quote Originally Posted by 785 lugs View Post
    You just pulled the 4 long bolts not the ones that go through the hull correct .
    if you just pulled the long ones you are fine
    What he said ^^^^^

  4. #4
    I pulled the 4 long bolts & the 4 nuts. The studs are still in the hull though, they have not been moved.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by yeehaa View Post
    I pulled the 4 long bolts & the 4 nuts.
    The studs are still in the hull though, they have not been moved.
    Did you move, or remove, the pump base - the part that is sealed against the hull?

  6. #6
    Yes I did remove pump base. I would think that since the studs that go into the hull were not moved the pump base will go back on in the same alignment position.

  7. #7

  8. #8

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    I've pulled the housing off the hull before and did not reshim the motor and everything was fine .I would bolt it up and go

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pump shaft too short after engine removal
    By A1RENCH in forum Kawasaki How To & FAQs
    Replies: 6
    Last Post: 06-26-2011, 12:49 PM
  2. 1995 Polaris 750sl Oil Pump removal - what to remove after pump?
    By invetteve in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 06-06-2011, 07:08 PM
  3. alignement after pump wedge!!
    By pass1 in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-20-2010, 02:24 PM
  4. pump removal, driveshaft issue: advice needed
    By bblades262 in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-21-2010, 10:04 PM
  5. Performance Fuel Pump,is it needed for stage2?
    By novice_4 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-03-2006, 10:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •