Results 1 to 9 of 9
  1. #1
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196

    02 GP 1200 engine problems

    Hey guys, I brought my GP1200 in to Riva for a 100 hour service even though it only has 78 hours on it. I thought it would be the right thing to do,I have only owned it for about a month and put about 18 hours on it.I havent had any problems with it but I thought it would be smart to let the professionals change filters and do lubrication. I was wrong,when I took it out this weekend I tried to jump the fisrt wave and the engine bogged like it was out of fuel. I changed the fuel selector to reserve and idled it back through the very rough inlet. The fuel was new and the tank was full. The engine stays running but the exhaust sounds different and the engine bogges when you throttle up. Any suggestions on where to look? Thanks for any help anyone can give.


  2. #2
    im in the same boat you are engine makes a funny sound almost like it sounds like a four stroke and that ethanol gas is leaving a brown residue on the water separator

  3. #3
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Did you bring this to Riva's attention?

  4. #4

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    what year gp?
    most time they won't water test (cost xtra money)
    later cd

  5. #5
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Chip its a 02 as stated in the titile.

    Also to me it sould like my rxp when i hit the tops tip over protection does gprs have this?

  6. #6

    Join Date
    Jan 2006
    Location
    Ft. Walton Bch
    Posts
    92
    +1
    2

    re

    Sounda as though you blew an exhaust hose. The burnt gases are trapped in the hull therfore the engine cannot breath. Remove the seat connect to hose and crank ski if its really loud that's the problem. Feel directly under the larger black hose leaving the exhaust to the rear of the boat "probably find a lare split".

    Hope this helps

  7. #7

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    ya you need to pull seat and run on hose see if something strange,carb ski do not have tip over sensor,if still have problem 86 fuel selector

    later cd

  8. #8
    Canadian POWERHOUSE CanadianGPR's Avatar
    Join Date
    Dec 2005
    Location
    Vancouver, British Columbia
    Posts
    382
    +1
    1
    Sounds like your 02 has the same problem mine had. It had a missing reed petal. The exhaust sounded like the rear hose had come off, and the machine wouldn't go over 5000 rpms.

    Rich

  9. #9
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Take it back and ask why.

    Certainly they won't charge you for a diagnostic after working on your ski.

    Before you go, check the easy stuff:\
    1. All the spark plug caps pushed on?
    2. Correct spark plug?
    3. Any strange sounds on the trailer (pump noise, engine rattle, exhaust)
    4. Fuel lines on the filters look right?
    5. Did you try and run it in the reserve position? Possible wore out selector switch.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 gp 1200?? for sale in IL.
    By 785 lugs in forum Yamaha Classifieds
    Replies: 0
    Last Post: 10-16-2008, 06:44 PM
  2. GP 1200 electrical problem - HELP NEEDED!!
    By ant11980 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-17-2008, 09:01 AM
  3. 02 gp 1200 tach/gauge
    By strictlymarine in forum Yamaha Classifieds
    Replies: 5
    Last Post: 08-10-2008, 03:47 PM
  4. 02 xlt 1200 rpm problems
    By saxy415 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-10-2008, 06:27 AM
  5. 02 xlt 1200 carb problem
    By vomitspot in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 04-26-2007, 04:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •