Results 1 to 5 of 5
  1. #1

    2006 RXP questions

    i just got a new RXP 2006 and I bought the RIVA metal washers and ceramic bearings. They are being put on by my dealer in Nashville, TN right now. The ski only has 32 hours on it currently. I ride it in a lake that has a dam nearby and it always has tons of debris in it from the currents. Is there anything else that I need to do to it for maximum reliability? Any other shotty parts on it that I should go ahead and replace while it is in the shop?


  2. #2

    Join Date
    Jul 2008
    Location
    Peterstown, WV
    Posts
    100
    Probably only the washers need changed. I've heard bad things about the ceramic bearings.

  3. #3
    suck my wake's Avatar
    Join Date
    Apr 2006
    Location
    Sugar Grove IL
    Posts
    2,872
    +1
    12
    If you have lots of debris in your lake I would recomend putting in a stainless wear ring. With the stock plastic wear ring it seems to let things get wedged between the prop and wear ring causing major cavitation and haveing to flip the ski over to have it removed. This won't happen with a stainless wear ring installed. Just a tip

  4. #4
    Quote Originally Posted by castiljd View Post
    Probably only the washers need changed. I've heard bad things about the ceramic bearings.
    Even the Ceramic RIVA bearings that i bought on this site. I saw a thread where they were recommended over the ones that were in there.
    Also I took the RXP out for the first time yesterday and when I first got it out there it seemed to be slipping for about the first 15 mintes that I was on the lake. The RPM's were up and down and when I would go full throttle it was bogging down for a while. And then all of the sudden it just woke up and was hauling ass. Seemed to run perfect after that, anyone know what might have been the problem? There was no debris in the grate or the prop, that was the first thing that I checked.

  5. #5
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by bsc819 View Post
    Even the Ceramic RIVA bearings that i bought on this site. I saw a thread where they were recommended over the ones that were in there.
    Also I took the RXP out for the first time yesterday and when I first got it out there it seemed to be slipping for about the first 15 mintes that I was on the lake. The RPM's were up and down and when I would go full throttle it was bogging down for a while. And then all of the sudden it just woke up and was hauling ass. Seemed to run perfect after that, anyone know what might have been the problem? There was no debris in the grate or the prop, that was the first thing that I checked.
    The ceramics only fail if not installed correctly!! I ran mine on my Stage III for 80 hours without a hiccup..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXP question..
    By bsc819 in forum 4-Tec Performance
    Replies: 23
    Last Post: 05-29-2009, 08:09 AM
  2. 2006 rxp questions - error
    By jerryspringer in forum 4-Tec Performance
    Replies: 1
    Last Post: 12-11-2008, 08:09 AM
  3. Replies: 5
    Last Post: 06-25-2008, 02:40 PM
  4. New Member 2006 RXP question 2?
    By Airborne68007 in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2008, 01:30 PM
  5. New Member Question for 2006 RXP.
    By Airborne68007 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-13-2008, 10:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •