Results 1 to 3 of 3
  1. #1

    rpm's o.k., lost top end

    At the end of last season, I let my nephews ride my '98 XPL. Before they took it out, it turned 6800 rpm, and would hit 62-63mph. When I took it to the ramp, it still turned 6800 rpm; but, top end was about 52mph. A check underneath shows nothing blocking the intake, and the impeller looks good. Thoughts (other than keep the nephews off it)?

  2. #2
    mibunkerking's Avatar
    Join Date
    Aug 2008
    check your wear ring clearence

  3. #3

    Join Date
    Jul 2005
    Are you reading us the speedo'? if so they are never right, use a GPS and report back.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gpr lost top end speed
    By rich.allen in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-09-2012, 10:48 AM
  2. 07' 250X lost top end mph after parking for 20 min?
    By bzyguy in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 07-23-2012, 06:00 PM
  3. 05 R12-X Drops RPM and Boost on Top End
    By cconigliaro in forum Honda Performance
    Replies: 2
    Last Post: 01-22-2012, 03:37 PM
  4. 99 SLTH - Top End Runs great, bogs down at low RPM
    By thiagoavila in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-29-2010, 12:02 PM
  5. Lost top speed, rpm and acceleration. HELP!!!
    By zRaXcPk in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-30-2008, 05:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts